Results 1 to 4 of 4
  1. #1

    vim - how to enable syntax highlight

    I recently expanded my server from one to three and the vim on the new two servers don't do the syntax highlight. I think it has something to do with the config file /etc/vimrc, but I couldn't figure out how to change it.

    Not only the no highlight, there are many other missing functions e.g.

    1. remember the last line that were being edited.
    2. showing line number, character position when editing

    I also notice another difference that my old server has all .viminfo and its related files under root directory, but the new two servers don't.

    Anyone know how to configure/fix this, please let me know. Thank you.

    Jay
    Edit/Delete Message

  2. #2
    anyone please help?

  3. #3
    Join Date
    Dec 2001
    Location
    Northern Virginia
    Posts
    238
    Try enabling it manually by yntax on. You may need to add that to your vimrc file. et number should enable line numbering.

  4. #4
    Join Date
    Dec 2001
    Location
    Northern Virginia
    Posts
    238
    the smiley is supposed to be a colon then the letter 's'

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •