Results 1 to 2 of 2

Thread: apache 2.0.39

  1. #1
    Join Date
    Nov 2001

    apache 2.0.39

    anyone have a problem getting php 4.2.1 to work with apache 2.0.39?

    It was fine with 2.0.36 -- but im upgrading because of that security issue.

    (when starting with apachectl)

    First time i did it, php compiled right
    compiled it like this:
    ./configure --with-mysql --with-apxs2=/usr/local/apache2/bin/apxs --enable-track-vars

    edited httpd.conf, it had loadmodule modules/libphpwhatever
    Then when starting with apachectl, i got:

    httpd: module "sapi_apache2.c" is not compatible with this version of Apache.
    Please contact the vendor for the correct version.

    so i rm -rf'ed the php src dir, and apache 2.0 dir
    re d/l'ed them
    untar'ed em
    then re compiled apache, worked, but php
    php_functions.c:93:27: missing binary operator before '!'
    make[3]: *** [php_functions.lo] Error 1
    make[3]: Leaving directory `/home/dev/ap2.0/php-4.2.1/sapi/apache2filter'
    make[2]: *** [all-recursive] Error 1
    make[2]: Leaving directory `/home/dev/ap2.0/php-4.2.1/sapi/apache2filter'
    make[1]: *** [all-recursive] Error 1
    make[1]: Leaving directory `/home/dev/ap2.0/php-4.2.1/sapi'
    make: *** [all-recursive] Error 1

    so basically
    all im saying is
    apache 2.0.39 doesn't seem to work right with php 4.2.1
    php won't even compile to begin with
    it compiles if i dont use it with apache 2.0

    has anyone ran into this problem? php 4.2.1 works fine with apache 2.0.36 though.

    i guess i'll wait, maybe php has to update their php 4.2.1 to suit apache 2.0.39 -- kind of like mod ssl and apache 1.3.x

  2. #2
    Join Date
    Jan 2002
    PHP's support for Apache 2 is still experimental, so you should expect alot of broken code.

    Apache 2 has just been stableized, so the PHP folks didn't have time yet to make the final tuning of the module.

    I guess that by the next version of PHP, PHP will compile with all 2.0.x versions of Apache with no trouble.
    Ahmad Alhashemi
    PHP, Apache, C, Python, Perl, SQL
    18 related BrainBench certificates

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts