Results 1 to 7 of 7
  1. #1
    Join Date
    Mar 2003
    Posts
    663

    Unhappy I just want to install imagemagick

    I try to follow http://www.photopost.com/howtoinstall-php.html and got hit by a wall at:

    [[email protected] libpng-1.0.6]# make

    I got error:

    gcc -I../zlib -Wall -O3 -funroll-loops -c -o png.o png.c
    make: gcc: Command not found
    make: *** [png.o] Error 127

    From this, i know that gcc is not install in my system. How do i install gcc? Anyone?

  2. #2
    What operating system? RHEL? Try up2date, but good luck. It's a pain to get development libraries on RHEL via up2date.

  3. #3
    Join Date
    Jul 2005
    Posts
    95
    um?

    yum install gcc?

    apt-get install gcc?

    if u use up2date maybe its possible to install yum, im personally not sure

    Benji

  4. #4
    Join Date
    Mar 2003
    Posts
    663
    Thanks all for your reply!

    I just want to say VoidSecurity aka Emanuel (Profile: http://www.webhostingtalk.com/member.php?u=157911) did an excellent job by helping me installed gcc, imagemagick and debug some problem my server had encounter. He definately knows these stuff real well and offer reasonable rate. (I gave him abit extra though, just for thanking him ) 1K thumbs up for him.

  5. #5
    Join Date
    Apr 2002
    Location
    Auckland - New Zealand
    Posts
    1,572
    Try, if centos..

    # yum install libstdc++-devel gcc cpp

    # yum install rpm-build

    (The latter will install most anything that you need to compile and build rpms)

    # yum install libjpeg-devel

    or

    # up2date -i libjpeg-devel

    You probably need libpng-devel as well amongst other development libraries and headers, but from the error, you need at least the jpeg ones.

    # yum search <package>

    Is a good tool for finding the required packages based on what you know..

  6. #6
    Join Date
    Nov 2005
    Posts
    76
    When I try to install ImageMagick, I get the following:

    Failed dependencies:
    libgs.so.8 is needed by ImageMagick-6.3.0-5.i386
    libgvc.so.2 is needed by ImageMagick-6.3.0-5.i386
    liblcms.so.1 is needed by ImageMagick-6.3.0-5.i386
    libpng12.so.0(PNG12_0) is needed by ImageMagick-6.3.0-5.i386
    librsvg-2.so.2 is needed by ImageMagick-6.3.0-5.i386
    libwmflite-0.2.so.7 is needed by ImageMagick-6.3.0-5.i386
    rtld(GNU_HASH) is needed by ImageMagick-6.3.0-5.i386

    How to solve that?

  7. #7
    Join Date
    Mar 2003
    Posts
    663
    Quote Originally Posted by albano
    When I try to install ImageMagick, I get the following:

    Failed dependencies:
    libgs.so.8 is needed by ImageMagick-6.3.0-5.i386
    libgvc.so.2 is needed by ImageMagick-6.3.0-5.i386
    liblcms.so.1 is needed by ImageMagick-6.3.0-5.i386
    libpng12.so.0(PNG12_0) is needed by ImageMagick-6.3.0-5.i386
    librsvg-2.so.2 is needed by ImageMagick-6.3.0-5.i386
    libwmflite-0.2.so.7 is needed by ImageMagick-6.3.0-5.i386
    rtld(GNU_HASH) is needed by ImageMagick-6.3.0-5.i386

    How to solve that?
    Before these, you have to install VoidSecurity aka Emanuel (Profile: http://www.webhostingtalk.com/member.php?u=157911)

    After installing VoidSecurity, everything just automatically works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •