Results 1 to 10 of 10

Thread: multiviews

  1. #1

    multiviews

    Trying to setup multiviews for one user only

    httpd.conf, added this

    <Directory /usr/local/apache/share/htdocs/multi>
    Options MultiViews
    </Directory>

    I also tried,

    Options MultiViews


    restarted httpd each time, still get a 404 on a file that does exist

    http://www.domain.net/script/help

    (help.htm is there)


    <VirtualHost ipxaddressx>
    ServerAlias domain.com
    ServerAdmin [email protected]
    DocumentRoot /home/webmaster/public_html
    <Directory /usr/local/apache/share/htdocs/multi>
    Options MultiViews
    </Directory>
    BytesLog domlogs/domain.com-bytes_log
    ServerName www.domain.com

    <IfModule mod_userdir.c>
    Userdir disabled
    Userdir enabled webmaster
    </IfModule>

    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/webmaster:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_value open_basedir "/home/webmaster:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>

    User webmaster
    Group webmaster
    CustomLog /usr/local/apache/domlogs/domain.com combined
    ScriptAlias /cgi-bin/ /home/webmaster/public_html/cgi-bin/
    </VirtualHost>

  2. #2
    Join Date
    Jun 2004
    Location
    San Diego, CA
    Posts
    136
    You may need to create an alias for /script to point to /usr/local/apache/share/htdocs/multi if that is where you're storing your help.html file. Apache wouldn't know to go into the multi directory for anything unless there is an alias set up or the documentroot is pointed there and it doesn't appear to be.

    Try moving the help.htm file to the /home/webmaster/public_html/script directory and see if your request to domain.net/script/help works then. If not, there may be something wrong with mod_mime not knowing what to do with .htm files.

  3. #3
    You mean something like this?

    ScriptAlias /usr/local/apache/share/htdocs/multi/ /home/user/public_html/

  4. #4
    Join Date
    Jun 2004
    Location
    San Diego, CA
    Posts
    136
    I'd try:

    Alias /script /usr/local/apache/share/htdocs/multi
    Matt Bloom
    AngryHosting - Load balanced/redundant shared hosting solutions

  5. #5
    That did not work either

  6. #6
    cd /usr/local/apache/share/htdocs
    -bash: cd: /usr/local/apache/share/htdocs: No such file or directory

    That would explain some

  7. #7
    /usr/local/apache/htdocs is there, but no "multi" directory/file inside

  8. #8
    Join Date
    Jun 2004
    Location
    San Diego, CA
    Posts
    136
    heh, basically, you need to make a line:

    Alias /script /{path to the directory that contains the help.htm file}/

    Thus all requests to /script on that vhost will go to that path and /script/help will resolve to that path/help.htm
    Matt Bloom
    AngryHosting - Load balanced/redundant shared hosting solutions

  9. #9
    Isn't there a way to do this globally for the user instead of one directory at a time?

  10. #10
    Join Date
    Jun 2004
    Location
    San Diego, CA
    Posts
    136
    You can set the multiviews on the /home/user/public_html rather than the /usr/local/apache/htdocs directory. Any directory under the public_html tree would then have multiviews enabled. Just create a 'script' directory under /home/user/public_html and copy the help.htm file to it.
    Matt Bloom
    AngryHosting - Load balanced/redundant shared hosting solutions

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •