Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2006
    Pennsylvania, USA

    Question Windows 2k3 Dedi PHP Help needed

    Dedicated Server Specs:

    Windows Server 2003 R2
    IIS 6.0
    PHP 5.1.6
    MySQL 5.0.x
    x64bit Processor Architecture


    I have PHP and MySQL running successfully on the server, and am able to use each of them seperately, however when trying to use PHP to connect using both the mysql_* and mysqli_* libraries, I receive the error that php "Can't create TCP/IP socket (5 )". I've tried editting PATH settings, turning IIS to run worker processes in IIS 5.0 mode, adding securities to the MySQL directory, but nothing seems to work.

    I need to find a solution to this, have any of you experienced and conquered it?

    I would greatly appreciate any feedback, thanks in advance.
    Last edited by sirius; 11-01-2006 at 11:08 AM.

  2. #2
    Join Date
    Jul 2006
    Well this is more suited to Technical/Security issues, but I'll give you my misinformed 2 cents anyways...

    Check your PHP.INI and sure nothing is disabled that isn't supposed to be.... PHP is a dog that needs to be leashed for security reasons, unfortunately the leash can sometimes get too tight.

  3. #3
    Join Date
    Nov 2002
    * Moved to Technical and Security Issues....

    I support the Human Rights Campaign!
    Moving to the Tampa, Florida area? Check out life in the suburbs in Trinity, Florida.

  4. #4
    I'm working with Aaron on this server, and I changed back to the default settings in the 'php.ini-dist' file (with our extensions enabled of course) and this did not fix the issue.

  5. #5
    Join Date
    Sep 2003
    Montreal, Canada
    5.7 I'm installing on a 64-bit box and all I get is a 500 error page!
    This just in, from Ryan Hubbard:
    On 64 bit IIS loads all extensions in 64 bit mode by default. Since php5isapi.dll is 32 it freaks out but doesn’t give an errors just a 500 error on php pages. So in order to get it to work on IIS 6 64-bit you need to run the following at the command line.
    cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1
    This enables both 64 and 32 bit extensions.
    Perhaps this might do it?

  6. #6
    Actually, that post you just quoted is erroneous, it doesn't enable -both- x64 and x86 extensions, it just switches to x86 instead of x64. When you do that and restart IIS, it will actually fail if you have ASP.NET installed on it using the .NET Framework 2.0. If you do that and it does fail, just run your Windows update and the .NET Framework will update itself a few times so that it adds a 32-bit ISAPI filter to your IIS, thereby solving the problem.

    But no, that doesn't solve the problem, thanks however.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts