I am trying to setup IIS 6 to allow web developers to connect up to the web root of a website via WebDav and work on site files including .asp and .aspx files.

I have setup a website for this purpose in IIS. The home directory is mapped to a local folder on the machine. Under the 'home directory' tab all the permission boxes are checked ('script source access, read, write, etc...). Execute permissions are set to 'scripts and executables'. I've also removed .asp from the 'application extensions' list accessed from the 'configuration' tab. Basic authentication is turned on under 'directory security/authenticati on and access control'. I do not have URLScan installed, so any filtering is by IIS only.

This is all working as expected; I can mount the WebDav connection in Windows Explorer and navigate, view and open/save files. I can also access the website via a browser and browse directories/view browser appropriate files, etc. The problem is that I cannot access any .asp files at all. If I look in the logs for the website I get a entry for the WebDav request (PROPFIND) with a 404 error. The file *is there* I just can't access it. Other files (.html, .css., .jpg, etc.) work fine.

What can I enable/disable in IIS to make this work?? I have spent hours on this already and about to give up.