Results 1 to 7 of 7
  1. #1

    Unable to receive mail

    So i googled a bunch to try and find out why I can't receive mail, and apparently it is because a default sendmail installation only binds to localhost and not public ip.

    So I went into ALL .cf and .mc files in /etc/Mail to find the line that I needed to comment out, but to no avail.
    My config files do not contain such a line.

    Then I read in the freebsd handbook that on a default freebsd installation, I should at least be able to receive email to [email protected].
    However not even that works, even though I'm running my own dns for the domain that my box uses.

    I have an MX record in my master zone file for the domain, and an a-record that points to the box main ip.

    If anyone has any ideas feel free to give me a holler.

  2. #2
    Join Date
    Nov 2003
    Location
    Auckland, New Zealand
    Posts
    584
    did you restart sendmail after the config changes ?
    BLUETRIDENT.NET - Reliable Shared, Reseller and Dedicated Hosting Solutions Provider
    Managed Hosting with Personal Service
    Highspeed Content Servers, Lighttpd, Ruby on Rails, Cluster Servers & Rich Web Application Hosting

  3. #3
    Yep I did make restart in /etc/mail

  4. #4
    Also, yesterday I received a google mailer daemon error that the emails could not be sent to the recipient.

    Today after I made some changes it seems like I get no such error.
    I have edited both local-host-names and virtusertable to the appropriate values, but I have a feeling sendmail is actually receiving the mail only it;'s not sending it to the appropriate inboxes.

    So, if anyone has any ideas on that I'll be googling to try and find a solution.

  5. #5
    Still not working..

    I did make all in /etc/mail which created some my.hostname.mc file, which is good.

    Although it had no DAEMON_OPTIONS(`Port=smtp, Name=MTA')dnl line which is printed on every website I go to about sendmail that it must be uncommented.

    So I just added the line and reinstalled/restarted, still no dice.

    I really need help on this guys.

  6. #6
    I have to bump this because this is killing me.
    Any help appreciated again.

  7. #7
    Sorry but this just won't work, so I installed postfix, and everything seemed to go ok except I get this error when trying to send a mail to both local users and remote mailboxes:

    Oct 21 04:16:07 orion postfix/postdrop[64854]: warning: unable to look up public/pickup: No such file or directory

    Naturally I googled this message but nothing helped.
    If anyone has any ideas I'd appreciate it because this is doing my head in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •