Results 1 to 7 of 7
  1. #1
    Join Date
    Jun 2001
    Posts
    68

    Can't upload htaccess file

    It's on my own unix server and I have no idea where to look.

    My ftp program gives me this error:
    553 Prohibited file name: .htaccess
    ERROR:> Access denied.
    I have tried renaming without the dot and upload, but it won't let me rename back to the name with the dot.

  2. #2
    Join Date
    Apr 2003
    Location
    UK
    Posts
    2,560
    what ftpd?

    if its proftpd, check your denyfilter in your config

  3. #3
    Join Date
    Jun 2001
    Posts
    68
    it's pure-ftpd...

    I guess this setting should be ok.....
    ProhibitDotFilesWrite no
    ProhibitDotFilesRead no
    so it's something else

  4. #4
    Join Date
    Nov 2003
    Location
    Auckland, New Zealand
    Posts
    584
    Generally if you have this issue, you can upload any file, and then rename the file to .htaccess.
    BLUETRIDENT.NET - Reliable Shared, Reseller and Dedicated Hosting Solutions Provider
    Managed Hosting with Personal Service
    Highspeed Content Servers, Lighttpd, Ruby on Rails, Cluster Servers & Rich Web Application Hosting

  5. #5
    Join Date
    Jun 2001
    Posts
    68
    I can upload as htaccess without the dot, but when I try to rename back to .htaccess it won't let me and gives me the same error message...

  6. #6
    Are you sure your pureftpd use the pure-ftpd.conf file edited by you ?

  7. #7
    Join Date
    Jun 2001
    Posts
    68
    Quote Originally Posted by flashwebhost
    Are you sure your pureftpd use the pure-ftpd.conf file edited by you ?
    No not really... I just assumed that it did.


    I found this in the docs folder FAQ:

    * How to restrict access to dot files ?

    -> Is there an option to prevent people from accessing "." files/dirs (such
    as .bash_history, .profile, .ssh ...) EVEN if they are owned by the user ?
    (William Kern)

    Yes. '-x' (--prohibitdotfileswrite) denies write/delete/chmod/rename of
    dot-files, even if they are owned by the user. They can be listed, though,
    because security through obscurity is dumb and software shouldn't lie to
    you. But users can't change the content of these files.

    Alternatively, you can use '-X' (--prohibitdotfilesread) to also prevent
    users from READING these files and going into directories that begin with
    "." .

    but can't figure out where -x is set....

    <edit> Just noticed that -x is the same as prohibitdotfileswrite </edit>

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •