Results 1 to 4 of 4
  1. #1

    Apache will not find indexes

    I am running apache 2 and it will not find the indexes of my folders...

    I have the DirectoryIndex Directive set as:

    Code:
    DirectoryIndex index.htm index.html index.php index.shtml index.cgi index.pl index.xhtml

  2. #2
    Join Date
    Sep 2006
    Location
    Texas
    Posts
    38
    in your Directory statement, you may need to enable the indexes option.

    i.e.

    Code:
    Options Indexes
    as in

    Code:
    <Directory /home/*/public_html>
        AllowOverride FileInfo AuthConfig Limit
        Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    ...
    Kristopher E.J.
    http://www.SSAHost.com
    Stable, Supported, Affordable.

  3. #3
    Join Date
    Nov 2005
    Posts
    352
    Quote Originally Posted by SSA-Kris
    in your Directory statement, you may need to enable the indexes option.

    i.e.

    Code:
    Options Indexes
    as in

    Code:
    <Directory /home/*/public_html>
        AllowOverride FileInfo AuthConfig Limit
        Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    ...
    "Options Indexes" is only used when none of the files listed in the "DirectoryIndex" exist. In other words, as long as there is a file named either "index.htm", "index.html", "index.php", "index.shtml", "index.cgi", "index.pl", or "index.xhtml", that file should be displayed.

    Does one of those files exist in the directory in question? Is the file named properly (e.g., no spaces in the name, all lower case, etc.)?

    Or are you looking to have apache actually generate a listing of the files in that directory? If so, then the "Options Indexes" directive would be needed.

  4. #4
    What is your apache configtest showing?

    Provide some error log and access log for further diagnosis.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •