Results 1 to 12 of 12
  1. #1
    Join Date
    Apr 2005
    Location
    Istanbul
    Posts
    763

    Question High Load - DSSL Process

    Hello

    I have a high load problem on a VPS there are lots of DSL processes how can i fix this? Do you have any ideas?

    # ps aux | grep DSSL
    root 10229 0.0 0.3 7916 3620 ? S Sep23 0:21 /usr/local/apache/bin/httpd -DSSL
    nobody 31890 0.0 0.4 9180 4796 ? S 11:30 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 1708 0.0 0.4 8144 4176 ? S 11:42 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 1713 0.0 0.4 8152 4556 ? S 11:42 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 1919 0.0 0.4 8144 4164 ? S 11:43 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 2341 0.0 0.4 8056 4160 ? S 11:45 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 2346 0.0 0.4 8056 4244 ? S 11:45 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 2347 0.0 0.4 8056 4164 ? S 11:45 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 2508 0.0 0.4 8056 4268 ? S 11:46 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 2515 0.0 0.4 8056 4276 ? S 11:46 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 2523 0.0 0.4 8144 4112 ? S 11:46 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 2683 0.0 0.4 8056 4296 ? S 11:47 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3033 0.0 0.4 8056 4132 ? S 11:49 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3035 0.0 0.4 8056 4108 ? S 11:49 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3036 0.1 0.4 8056 4120 ? S 11:49 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3109 0.0 0.4 8056 4100 ? S 11:50 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3163 0.0 0.4 8056 4136 ? S 11:50 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3243 0.0 0.4 8056 4132 ? S 11:50 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3300 0.0 0.4 8056 4060 ? S 11:50 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3513 0.0 0.4 8056 4104 ? S 11:52 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3825 0.1 0.4 8048 4020 ? S 11:54 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 3833 0.0 0.4 8056 4092 ? S 11:54 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4186 0.2 0.4 8048 4100 ? S 11:56 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4187 0.0 0.4 8056 4116 ? S 11:56 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4188 0.1 0.4 8048 3984 ? S 11:56 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4193 0.0 0.4 8056 4048 ? S 11:56 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4218 0.0 0.4 8056 4004 ? S 11:56 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4226 0.2 0.4 8136 4140 ? S 11:56 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4246 0.0 0.4 8056 4056 ? S 11:56 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4280 0.0 0.3 8048 3948 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4281 0.1 0.4 8056 4036 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4282 0.1 0.4 8048 4032 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4284 0.0 0.4 8056 4020 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4285 0.0 0.3 8048 3972 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4286 0.0 0.3 8048 3952 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4287 0.0 0.3 8048 3968 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4307 0.0 0.4 8048 4008 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4308 0.0 0.3 8048 3976 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4309 0.0 0.3 8048 3964 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4314 0.1 0.4 8048 4000 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4315 0.2 0.4 8048 4052 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL
    nobody 4318 0.0 0.4 8048 4040 ? S 11:57 0:00 /usr/local/apache/bin/httpd -DSSL

    In that time all the sites are offline, mysql is downed by me but the load is 20-30
    Kind regards

  2. #2
    Join Date
    Jun 2006
    Location
    NYC
    Posts
    1,446
    How much memory do you have? If you have 256MB I would recommend using the settings below.

    Timeout 200
    KeepAlive On
    MaxKeepAliveRequests 100
    KeepAliveTimeout 5
    MinSpareServers 5
    MaxSpareServers 10
    StartServers 5
    MaxClients 130
    MaxRequestsPerChild 35
    FiberPeer.Com | | REAL DDoS Protection | Cloud Hosting | VPS | Dedicated Servers | High Bandwidth Hosting | 1Gbps-10Gbps Unmetered
    FiberPeer DDoS Mitigation | ethProxy Upgraded! | 14-Years Experience | Emergency 24/7 Support
    Visit us @ www.fiberpeer.com

  3. #3
    Join Date
    Apr 2005
    Location
    Istanbul
    Posts
    763
    i have 768 mb memory i have keepalive off

    when i check from whm it shows:

    root 5.43 0.91 1.9
    Top Process %CPU 215 df -P
    Top Process %CPU 132 df -P
    Top Process %CPU 63.6 df -P

    why is root using cpu so much
    Kind regards

  4. #4
    Join Date
    Dec 2005
    Posts
    368
    Quote Originally Posted by serverorigin
    How much memory do you have? If you have 256MB I would recommend using the settings below.

    Timeout 200
    KeepAlive On
    MaxKeepAliveRequests 100
    KeepAliveTimeout 5
    MinSpareServers 5
    MaxSpareServers 10
    StartServers 5
    MaxClients 130
    MaxRequestsPerChild 35
    Why would you have such a low MaxRequestsPerChild?? That is the total number of requests a child will handle during its lifetime... unless you have some kind of horrible memory leak, that should be in the hundreds or even thousands.

    In fact the default setting is 10000, which should be fine unless there is a memory leak or there are wild swings in server load which cause times when too many children are sitting around doing nothing but wasting memory. But even so, 35 seems way too low.

  5. #5
    Join Date
    Jun 2006
    Location
    NYC
    Posts
    1,446
    I would rather it cycle the process than eat up memory. After much testing our servers run 20-30MB less memory and only 0.3-0.5 more load doing it this way.
    FiberPeer.Com | | REAL DDoS Protection | Cloud Hosting | VPS | Dedicated Servers | High Bandwidth Hosting | 1Gbps-10Gbps Unmetered
    FiberPeer DDoS Mitigation | ethProxy Upgraded! | 14-Years Experience | Emergency 24/7 Support
    Visit us @ www.fiberpeer.com

  6. #6
    Join Date
    Dec 2005
    Posts
    368
    Well I guess if you are running out of memory then it can help in that area. Have you also tried setting MaxMemFree? http://httpd.apache.org/docs/2.0/mod/mpm_common.html#maxmemfree

    That's the number of kbytes that each child process can keep allocated without freeing it (default is unlimited). I set it to 300 and it seems to have helped with memory usage.

  7. #7
    Join Date
    Jun 2006
    Location
    NYC
    Posts
    1,446
    Actually I haven't tried that. I will do some testing with that. Thanks
    FiberPeer.Com | | REAL DDoS Protection | Cloud Hosting | VPS | Dedicated Servers | High Bandwidth Hosting | 1Gbps-10Gbps Unmetered
    FiberPeer DDoS Mitigation | ethProxy Upgraded! | 14-Years Experience | Emergency 24/7 Support
    Visit us @ www.fiberpeer.com

  8. #8
    Can you type:

    ps aux

    please?

    You have /usr/local/apache/bin/httpd -DSSL running as root and also as nobody.

    I'm not sure if that's right. ps aux would show us what else is running and we'll be able to help further.

  9. #9
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    Quote Originally Posted by stephanhughson
    Can you type:

    ps aux

    please?

    You have /usr/local/apache/bin/httpd -DSSL running as root and also as nobody.

    I'm not sure if that's right. ps aux would show us what else is running and we'll be able to help further.

    Apache runs the main process as root to obtain port 80, and every process after that is run as nobody or the user configured in the httpd.conf. Its 100% normal to see something like that.
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  10. #10
    Oh yeah, ps aux|grep httpd shows it on mine too. I tried that command earlier but didn't see it. Oh well ...

  11. #11
    Join Date
    Jul 2003
    Location
    Goleta, CA
    Posts
    5,550
    do you have any sites using ssl? If not recompile apache without mod_ssl it's a waste of cpu and memory resources if it's not being used.
    Patron: I'd like my free lunch please.
    Cafe Manager: Free lunch? Did you read the fine print stating it was an April Fool's joke.
    Patron: I read the same way I listen, I ignore the parts I don't agree with. I'm suing you for false advertising.
    Cafe Owner: Is our lawyer still working pro bono?

  12. #12
    Join Date
    Apr 2005
    Location
    Istanbul
    Posts
    763
    Quote Originally Posted by pixelized
    do you have any sites using ssl? If not recompile apache without mod_ssl it's a waste of cpu and memory resources if it's not being used.
    Oh ok i am trying it now thank you
    Kind regards

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •