Results 1 to 4 of 4
  1. #1

    Custom Linux on Raq 550

    I have a Raq 550. I have been trying to put Linux on it via LFS(Linux From Scratch).

    I was able to put the drive into an external usb case and take it along with a livecd to an internet cafe, where I installed it. (For complicated reasons, I only have an ibook to work with, and I didn't want to mess with cross-compiling.)

    Because I only have an ibook, I do not have a serial port. (You have to buy a special usb adapter for macs, and the nearest mac store is a long, long way away.)

    Anyway, I get home, put it in the Raq, and... I get a kernel panic. Tried booting from the drive, tried booting from ROM and CMOS. Does anyone know the boot process of the Raq 550? I'm guessing it either can't find the kernel, or can't mount the drive. However, I made the filesystem xfs...

    Anyway, I'm sort of stuck (as far as I can figure out) without an "apple-ready" usb-serial adapter. (No drivers for the generics)

    Any suggestions would be greatly appreciated. Thanks!

  2. #2
    Join Date
    Jan 2004
    Location
    Singapore
    Posts
    1,032
    Try Strongbolt. It will load CentOS4 on your server.
    www.osoffice.co.uk

    It works with tha RaQ550 And we have been using it for a while and they run great. Currently it looks like they got an offer on the install disc.
    -=- GQ Hong -=-
    GalacNet WebMaster

  3. #3
    Join Date
    Aug 2006
    Posts
    275
    The other option is Rackstar -- can't (yet) compare them with Strongbolt, but there are a very traditional 550 i'face, but with upgraded everything (Linux, Apache, Perl, PHP, Mysql, etc). It's free but a PITA to install, and seems to run well.

  4. #4
    He can't install either distributions from an iBook.

    inbuninbu:
    Your RaQ 550 ROM doesn't support XFS. I'm pretty sure
    of that, unless you compiled and upgraded yourself..

    There is no BIOS on these, there is a firmware ROM instead.
    The latest is 2.10.3 and it has support for Ext3 but not XFS.
    IIRC. You can set the boot-disk from the LCD-buttons.

    Oh, you really need a nullmodem cable. You can buy any
    USB-Serial adaptor, no need for extortionate Apple-gear
    for that. There are many, many things that can go wrong
    with the firmware when you use custom Linux-kernels
    and installations.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •