Results 1 to 4 of 4
  1. #1
    Join Date
    Dec 2003

    Can't conect to FTP?

    Hi, just last night my FTP server was working perfectly and I was able to upload stuff. Earlier today I tried connecting using SmartFTP and I keep getting a "No connection could be made because the target machine actively refused it." error. Then it times out and tries to use active mode to conect, but it eventually times out again after using the PORT command.

    I've tried using the SmartFTP documentation, but none of their answers seem to help. I've also tried using FireFTP, which just times out when connecting so I don't think it's the client that's the problem. I'm absolutely sure that all the information is correct (username, password, port, host), because I haven't changed anything since last night (plus I retyped it anyways, to be sure). Nothing has been changed on the server end either. Does anyone have any ideas?

  2. #2
    Most likely it's a firewall issue. Are you behind a firewall?

    Try running following command from the client machine.

    telnet {IP or host name of the machine} 21

    If it refuses to connect, the TCP port 21 is blocked. Depending on connection mode, you may be using port 20 or high TCP ports for data transmission.
    Top Web Hosts
    Web hosting directory & resources

  3. #3
    From the error message we believe changing the mode from passive mode to active or viceversa could fix this issue.

    You can change the mode in firewall settings.
    Live Your DreamZ

  4. #4
    Join Date
    Dec 2003
    Thanks for the replies. I tried using telnet to connect to my ftp server, and I was able to successfully connect to port 22 without any issues. I've also tried switching from passive to active and it didn't help. If it helps at all, this is what happens when I try to connect:

    [18:25:41] Detected Server Software: PureFTPd
    [18:25:41] PWD
    [18:25:42] 257 "/" is your current location
    [18:26:21] CWD /public_html/
    [18:26:21] 250 OK. Current directory is /public_html
    [18:26:21] PWD
    [18:26:21] 257 "/public_html" is your current location
    [18:26:21] TYPE A
    [18:26:21] 200 TYPE is now ASCII
    [18:26:21] PASV
    [18:26:21] 227 Entering Passive Mode (x,x,x,x,x,x)
    [18:26:21] Opening data connection to x.x.x.x Port: 64485
    [18:26:21] MLSD
    [18:26:41] No connection could be made because the target machine actively refused it.
    Then if I try to connect again, it connects, but I don't see any files or directories. So if I try changing the directory it shows that message again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts