Results 1 to 4 of 4

Thread: egress problem

  1. #1

    egress problem

    Curl/curlssl is enabled on my server (cpanel/centos)

    I have APF with egress filtering enabled.


    I have OSCommerce installed on my website, and I use the UPS XML contribution to get shipping quotes for my customers during the checkout process. I have looked at the code, and it uses CURL to try to make a connection to: to retrieve the data.

    $ch = curl_init();
    curl_setopt($ch, CURLOPT_URL, "");
    // uncomment the next line if you get curl error 60: error setting certificate verify locations
    //curl_setopt($ch, CURLOPT_SSL_VERIFYPEER, 0);
    // uncommenting the next line is most likely not necessary in case of error 60
    // curl_setopt($ch, CURLOPT_SSL_VERIFYHOST, 0);
    curl_setopt($ch, CURLOPT_RETURNTRANSFER, 1);
    curl_setopt($ch, CURLOPT_HEADER, 0);
    curl_setopt($ch, CURLOPT_POST, 1);
    curl_setopt($ch, CURLOPT_POSTFIELDS, $xmlRequest);
    curl_setopt($ch, CURLOPT_TIMEOUT, 60);
    Where $xmlRequest is a string variable containing the XML to be sent to UPS for the request.
    It does not work unless I disabled egress filtering in apf odd enough. I do not know why. Port 443 is open / included. Any suggestions?

  2. #2
    Join Date
    Jun 2003
    Ukiah, California
    Do you get any error message or does it just not work? Check your error log if you aren't getting any errors through your browser.
    Jacob Turner -- Ringnebula Systems
    Managed IT solutions for small business

  3. #3
    It just times out

  4. #4
    I would suggest to flush the apf rules and then reset it back and also try to add the domain IP in the firewall and recheck again at your end.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts