Results 1 to 16 of 16
  1. #1
    Join Date
    Jan 2005
    Location
    Leeds, England
    Posts
    183

    cppop won't start. How can I fix/reinstall it?

    so the POP3 server won't start on my server, whenever I try and restart via WHM i get this:

    root 19493 0.0 0.0 2544 356 ? S 12:20 0:00 /usr/sbin/courierlogger -pid=/var/run/imapd.pid -start -name=imapd /usr/lib/courier-imap/libexec/couriertcpd -address=0 -maxprocs=40 -maxperip=30 -nodnslookup -noidentlookup 143 /usr/lib/courier-imap/sbin/imaplogin /usr/lib/courier-imap/bin/imapd Maildir
    root 19494 0.0 0.0 3008 456 ? S 12:20 0:00 /usr/lib/courier-imap/libexec/couriertcpd -address=0 -maxprocs=40 -maxperip=30 -nodnslookup -noidentlookup 143 /usr/lib/courier-imap/sbin/imaplogin /usr/lib/courier-imap/bin/imapd Maildir
    root 19500 0.0 0.0 2956 356 ? S 12:20 0:00 /usr/sbin/courierlogger -pid=/var/run/imapd-ssl.pid -start -name=imapd-ssl /usr/lib/courier-imap/libexec/couriertcpd -address=0 -maxprocs=40 -maxperip=30 -nodnslookup -noidentlookup 993 /usr/lib/courier-imap/bin/couriertls -server -tcpd /usr/lib/courier-imap/sbin/imaplogin /usr/lib/courier-imap/bin/imapd Maildir
    root 19501 0.0 0.0 2344 452 ? S 12:20 0:00 /usr/lib/courier-imap/libexec/couriertcpd -address=0 -maxprocs=40 -maxperip=30 -nodnslookup -noidentlookup 993 /usr/lib/courier-imap/bin/couriertls -server -tcpd /usr/lib/courier-imap/sbin/imaplogin /usr/lib/courier-imap/bin/imapd Maildir
    root 19507 0.0 0.0 3160 432 ? S 12:20 0:00 /usr/sbin/courierlogger -pid=/var/spool/authdaemon/pid -facility=mail -start /usr/libexec/courier-authlib/authdaemond
    root 19508 0.0 0.0 2716 600 ? S 12:20 0:00 /usr/libexec/courier-authlib/authdaemond
    root 19509 0.0 0.0 2716 604 ? S 12:20 0:00 /usr/libexec/courier-authlib/authdaemond
    root 19510 0.0 0.0 2716 604 ? S 12:20 0:00 /usr/libexec/courier-authlib/authdaemond
    root 19511 0.0 0.0 2716 604 ? S 12:20 0:00 /usr/libexec/courier-authlib/authdaemond
    root 19512 0.0 0.0 2716 604 ? S 12:20 0:00 /usr/libexec/courier-authlib/authdaemond
    root 19513 0.0 0.0 2716 604 ? S 12:20 0:00 /usr/libexec/courier-authlib/authdaemond


    cppop has failed, contact sysadmin
    how can I either fix this or reinstall cppop?

    thanks in advance.
    Last edited by sirius; 09-20-2006 at 01:43 PM.

  2. #2
    deinstall imap-uw,then
    /scripts/upcp --force

  3. #3
    Join Date
    Jan 2005
    Location
    Leeds, England
    Posts
    183
    Quote Originally Posted by fitesun
    deinstall imap-uw,then
    /scripts/upcp --force
    command deinstall not found

  4. #4
    Join Date
    Nov 2002
    Location
    WebHostingTalk
    Posts
    8,878
    * Moved to Technical and Security Issues....

    Sirius
    I support the Human Rights Campaign!
    Moving to the Tampa, Florida area? Check out life in the suburbs in Trinity, Florida.

  5. #5
    Quote Originally Posted by Omega-Mark
    command deinstall not found
    what OS you use?
    I mean that you should remove imap-uw

    at FreeBSD,you can pkg_delete imap-uw-****
    at Linux, you should rpm -e imap-uw-****

  6. #6
    Join Date
    Jan 2005
    Location
    Leeds, England
    Posts
    183
    redhat enterprise 4 i686

  7. #7
    Quote Originally Posted by Omega-Mark
    redhat enterprise 4 i686
    rpm -qa | grep imap

    you should found your imap package,then
    rpm -e imap***** --nodeps

  8. #8
    Join Date
    Jan 2005
    Location
    Leeds, England
    Posts
    183
    what do the asterisks represent? I just tried to do it (linux) without the -**** and it say's that imap-uw package isn't installed?

  9. #9
    Join Date
    Jan 2005
    Location
    Leeds, England
    Posts
    183
    Quote Originally Posted by fitesun
    rpm -qa | grep imap

    you should found your imap package,then
    rpm -e imap***** --nodeps
    using your first command i got courier-imap-4.0.4-3cp AND php-imap-4.3.9-3.15INLD which one should i do the 2nd command with?

  10. #10
    rpm -e courier-imap-4.0.4-3cp --nodeps

    /scripts/upcp --force

  11. #11
    Join Date
    Jan 2005
    Location
    Leeds, England
    Posts
    183
    ok did both of them and I still can't connect to pop3. and cppop won't restart/start via whm

    I can connect to mail via IMAP using outlook express but not pop3.

  12. #12
    Join Date
    Nov 2005
    Location
    /etc/fstab
    Posts
    1,274
    Cppop isn't a IMAP service. Its a pop3 service. But there are some bugs regarding the Imap/Maildir conversation in cpanel. It has been found recently. If that is your problem, this should fix the problem:

    Code:
    /scripts/courierup --force
    /scripts/eximup --force
    It appears that xinetd doesn't always reload correctly when it gets SIGHUP and the old imap will still continue to run.

    If this doesn't work, then please login to shell and run the following command:

    Code:
    service cppop start
    Let me know what it says.

    Regards
    Mellowhost - Providing High Quality Web Hosting Services since 2007
    SSD Cpanel Shared, SSD OpenVZ & KVM VPS Hosting
    A Hosting Provider with Complete SSD VPS & Shared Hosting.

  13. #13
    Quote Originally Posted by Omega-Mark
    ok did both of them and I still can't connect to pop3. and cppop won't restart/start via whm

    I can connect to mail via IMAP using outlook express but not pop3.
    Are you sure you reinstall it successfully? you should check whether another imap process running.

  14. #14
    Join Date
    Jan 2005
    Location
    Leeds, England
    Posts
    183
    ran both those commands and then when i ran service cppop start it says "cppop: unrecognized service"

  15. #15
    Join Date
    Nov 2005
    Location
    /etc/fstab
    Posts
    1,274
    Quote Originally Posted by Omega-Mark
    ran both those commands and then when i ran service cppop start it says "cppop: unrecognized service"
    Make a restart of your system and check what it says. It should up after the restart.

    Regards
    Mellowhost - Providing High Quality Web Hosting Services since 2007
    SSD Cpanel Shared, SSD OpenVZ & KVM VPS Hosting
    A Hosting Provider with Complete SSD VPS & Shared Hosting.

  16. #16
    Join Date
    Jan 2005
    Location
    Leeds, England
    Posts
    183
    rebooted the server and it still isn't connecting. (hasn't run cppop).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •