Results 1 to 6 of 6
  1. #1

    Php mail not working

    Php is not sending out emails from my server.

    /etc/eximmailtrap file doesnot exits
    eximmailtrap=0 in /var/cpanel/cpanel.config

    prevent nobody to send email is disabled in tweak setting.

    Perl is sending out mail perfectly but PHP is not.

    Can anyone suggest the solution?

    regards,
    AashX

  2. #2
    Join Date
    Aug 2006
    Location
    Earth
    Posts
    69
    can you paste the mailing php script here?

    Also, does it show any error while calling the php page on the browser?

  3. #3
    Join Date
    Oct 2004
    Location
    India
    Posts
    491
    Have you disabled the user nobody to send mail from the server through the Tweak Settings in the server ?
    ESC :wq!

  4. #4
    Join Date
    Apr 2002
    Location
    South Carolina
    Posts
    497
    check your hostname, make sure it is valid and resolves.
    Carolina Hosting Services
    http://www.carolinahosting.net | @CarolinaHosting | Facebook.com/CarolinaHosting
    VMware | cPanel | Linux | Softaculous | 16 Years Hosting Experience

  5. #5
    The script was working fine since years.. Last week i upgraded the php from 4.x to 5.0.x

    Every thing is fine. hostname is OK. Emails are going out with Perl script.
    I have not disabled 'nobody' from sending message.
    I have phpsuexec enabled.

    I doubt after the upgrade of php this script stoped working.

    No errors are shown by the script. It quitely reports that email is sent but the email is not sent.

    From perl script email goes out perfectly so not even spam filter i guess.

    any more suggestion?

    regards,
    aashx

  6. #6
    Join Date
    Nov 2004
    Location
    Australia
    Posts
    1,683
    check the system mail logs to see whether you can find out details on where the email went.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •