Results 1 to 6 of 6
  1. #1
    Join Date
    Feb 2004
    Location
    Los Angeles, CA
    Posts
    127

    Question TOMCAT and Web applications

    Hello,

    JSP is enabled on my windows VPS.
    - Now I can access http://<IP>:8080/ , but not for a domain which I've enabled JSP for, http://<domain>:8080/ (I got The page cannot be found error). How I should solve this? so I could open http://<domain>:8080/ fine?

    - Also I tried to upload WAR file in plesk, it goes well and I can see it's status as running in plesk panel (Tomcat web applications page for the domain). It is shown in plesk. but NOT in tomcat web aplication manager! http://<IP>:8080/manager/html. It seems that the WAR file which I've uploaded has NOT been created correctly under TOMCAT applications.

    Would you please advise me what are these problems and how to solve them?
    Thanks in advanced,
    Regards,
    Kevin.

  2. #2
    Join Date
    Sep 2004
    Location
    Aveiro - PORTUGAL
    Posts
    68
    Hello,

    You need to access using:

    http://youdomain.com:9080/AppName

    where "AppName" is the same name of application, showed in Plesk tomcat. (case sensitive)

    this app will not appear in tomcat manager.

    is very confuse, I know, but work.

    i dont understand why not work on 8080, and not appear in tomcat manager.

    let me know if work.
    Alvaro

  3. #3
    Join Date
    Feb 2004
    Location
    Los Angeles, CA
    Posts
    127
    Thank you Alvaro
    Yes it is working... But all clients should use that ugly (!) address for accessing their JSP pages!? Is there any way for changing this?

    Regards,
    Kevin.

  4. #4
    Join Date
    Jun 2006
    Posts
    88
    You could set up mod_jk. I just got done doing it and it's a huge PITA, and a huge resource hog (processor and memory) but it'll do what you want.

  5. #5
    Join Date
    Sep 2004
    Location
    Aveiro - PORTUGAL
    Posts
    68
    Quote Originally Posted by lmnop
    Thank you Alvaro
    Yes it is working... But all clients should use that ugly (!) address for accessing their JSP pages!? Is there any way for changing this?

    Regards,
    Kevin.

    Kevin,

    In Plesk control panel have a link direct to java app, but not work. In kb.swsoft.com, an article explain this problem, and to fix this is necessary to configure a ISAPI filter on IIS, this filter enable the users access the java apps by a friendly url.

    You can read the article here:

    http://kb.swsoft.com/article_154_982_en.html


    note: In my plesk servers this filter is installed, but not working.

    Alvaro

  6. #6
    Join Date
    Feb 2004
    Location
    Los Angeles, CA
    Posts
    127
    Thank you guys for your help.

    I'm working on it...!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •