Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2003

    Hd problems? : Logs aren't written / can't install rpm

    I had some major hd problems (apparently /var was corrupt) but it's ok now (i think).
    But i still have some strange things.

    I have a Centos box with DA, exim and apache.
    Now exim and apache are running and working but no logs are made.

    I think that mail sent to my server takes way too long to be delivered (10-30 minutes). So i check my exim version with exim -bV, its says: Exim version 4.24 #1 built 29-Feb-2004 05:20:37

    So i wanted to upgrade to 4.60,

    rpm -Uhv da_exim-4.60-1.i386.rpm
    error: cannot open Packages index using db3 - Permission denied (13)
    error: cannot open Packages database in /var/lib/rpm

    So i checked what was installed, and i see:
    rpm -qa | grep exim
    So can't I upgrade because it's already installed, or because of hd issues? And why isnt 4.6 running although it's installed?

  2. #2
    Join Date
    Mar 2003
    California USA
    rpm -e --justdb --nodeps --allmatches exim
    rpm -ivh da_exim-4.60-1.i386.rpm
    Steven Ciaburri | Proactive Linux Server Management -
    Managed Servers (AS62710), Server Management, and Security Auditing.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts