Results 1 to 5 of 5
  1. #1

    Unhappy New VPS, problems with yum

    Hi everyone,

    I just bought my first VPS hosting yesterday, at Future Hosting. So far, so good. Though, I must say it's a bit tough having to setup everything! (I can do it, but I'm not used to it.)

    First, I'd like to ask, how good is CentOS? I didn't have a choice of OS when I signed up, and maybe I would have prefered RedHat or Debian, but CentOS seems to take all RHEL RPM's. It seems to be quite famous among all the VPS hosting Web sites I've seen.

    Anyway, I'm having an issue with yum. I installed yum manually, since it didn't came pre-installed. For some reason, yum doesn't like the 'base' repository. (Unfortunately, the most useful!) If I run yum with that repository, everything works fine. But when I do include it, I always get a memory allocation problem.

    # yum -d 5 -y update | tail 7
    Not an install only pkg, adding to ts
    Updating: libtiff, i386
    Not an install only pkg, adding to ts
    Updating: xorg-x11-Mesa-libGL, i386
    Not an install only pkg, adding to ts
    Updating: netpbm, i386
    Not an install only pkg, adding to ts

    And the error output is the following:

    Traceback (most recent call last):
    File "/usr/bin/yum", line 30, in ?
    File "/usr/share/yum/", line 319, in main
    (errorcode, msgs) = tsInfo.resolvedeps(rpmDBInfo)
    File "/usr/share/yum/", line 326, in resolvedeps
    _ts = self.populateTs(addavailable = 1)
    File "/usr/share/yum/", line 285, in populateTs
    pkghdr = self.getHeader(name, arch)
    File "/usr/share/yum/", line 88, in getHeader
    pkghdr = clientStuff.readHeader(self.localHdrPath(name, arch))
    File "/usr/share/yum/", line 192, in readHeader
    h = rpm.headerLoad(
    File "/usr/lib/python2.3/", line 217, in read
    File "/usr/lib/python2.3/", line 276, in _read
    uncompress = self.decompress.decompress(buf)

    I have the latest versions of python, yum, and gzip. I tried disabled netpbm and some preceding packages (as listed above), but I get the error message nevertheless, so I suspect the error occurs when scanning for the header following netpbm. I thought the next packages it was scanning were finger-server and sendmail, but no success.

    Anyone can tell me what I can do? Thanks in advance!


  2. #2
    Join Date
    Aug 2004
    Hi Remi,

    I just bought one too. Yeah I'd prefer to have Debian too but Vik said there were not enough interests. So, please let's all make requests for Debian!

    Regarding on the yum issue (I actually can't even install it cuz I can't find the RPMs for CentOS 4.2), apparently there is a template with yum pre-installed. So you can ask Vik or contact the support.


    P.S. I didn't do much on my VPS so far, but from testing the speed, etc, it's very good!

  3. #3
    Getting the RPM's is really easy. I found no direct link to their RPM repository, but I just went to download an ISO and once on their file server, just browsed the parents directory, and found the directories containing all RPM files!

    http: // isoredirect. centos. org/ centos/ 4/ apt/ i386/
    (Sorry about the spaces. The board won't let me post URL's until I reach 5 posts.)

    Turns out that I installed the wrong version of Yum I found somewhere else. I just updated Yum this morning and hopefully everything will be working fine. However, it's requiring 'yumconf' to be installed, but I can't find a package as such...

  4. #4
    I just needed to install the centos-release RPM package. Now everything works fine!

  5. #5
    Another tip: once Yum is installed, I recommend you enable all repositories in /etc/yum.repos.d/Centos-Base.repo. Some are disabled by default with 'enabled=0,' and you simply need to set that to 1. Those repositories contain useful packages like Apache 2, MySQL 5, and PHP 5. The other repositories have only Apache 1, MySQL 4, and PHP 4, which I didn't want.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts