Results 1 to 2 of 2
  1. #1

    all addons show main domain

    Cpanel is a pain in the ***, seriously.

    After the mod security bug, now this. One client's info was deleted from httpd.conf (seen this happen due to rebuildhttpdconf script)

    I re-added the info manualy, the virtual hosts by using the list found in /var/cpanel/users/username


    I ran updateuserdomains, rebuildhttpconf, rebuildnamedconf, restarted cpanel, named, httpd, same problem.


    Example virtualhost of sub-domain/addondomain

    Code:
    <VirtualHost xxx.xxx.xxx.xxx>
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/mainusername/:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    <IfModule mod_php5.c>
    php_admin_value open_basedir "/home/mainusername/:/usr/lib/php:/usr/local/lib/php:/tmp"
    </IfModule>
    User mainusername
    Group mainusername
    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled mainusername
    </IfModule>
    BytesLog domlogs/add-on-domain.com-bytes_log
       ServerName add-on-domain.com
       UseCanonicalName  off
       ServerAdmin [email protected]
       CustomLog /usr/local/apache/domlogs/add-on-domain.com combined
       Options -ExecCGI -Includes
       ScriptAlias /cgi-bin/ /home/mainusername/public_html/addonuser/cgi-bin/
       DocumentRoot /home/mainusername/public_html/addonuser
       User mainusername
       Group mainusername
       ServerAlias www.add-on-domain.com
       <IfModule mod_userdir.c>
          Userdir disabled
          Userdir enabled mainusername
       </IfModule>
       <IfModule mod_php4.c>
          php_admin_value open_basedir "/home/mainusername:/usr/lib/php:/usr/local/lib/php:/tmp"
       </IfModule>
       <IfModule mod_php5.c>
          php_admin_value open_basedir "/home/mainusername:/usr/lib/php:/usr/local/lib/php:/tmp"
       </IfModule>
       BytesLog /usr/local/apache/domlogs/add-on-domain.com-bytes_log
    </VirtualHost>
    I corrected the document root and scriptalias, same problem

  2. #2
    Join Date
    Dec 2005
    Posts
    82
    Hello.

    Make sure you have the string

    NameVirtualHost xxx.xxx.xxx.xxx:80

    before your main domain configuration in apache, otherwise all requests will
    relate to the first website on this IP (as a rule it is your main domain)

    I hope this will work like a charm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •