Results 1 to 10 of 10

Thread: apache problem

  1. #1

    apache problem

    [email protected] [~]# service httpd restart
    /etc/init.d/httpd restart: configuration broken, ignoring restart
    /etc/init.d/httpd restart: (run 'apachectl configtest' for details)

    [email protected] [~]# /usr/local/apache/bin/apachectl configtest
    Syntax error on line 1193 of /usr/local/apache/conf/httpd.conf:
    Invalid command 'SSLEnable', perhaps mis-spelled or defined by a module not included in the server configuration

    I cannot compile via whm apache update (shows page not found when I click "start build"). I did upcp -force on release, stable and did not fix it. I did fixeverything, did not fix that either.

    Anyone know how to correct both issues? I used easyapache and did compile with ssl module enabled, but the above error still persists.

    I also cannot use /scripts/installzendopt (but wget works on anything else). Services are up otherwise. Even if I disable APF, the script still doesn't work.

  2. #2
    This is 1194 line from httpd.conf as error mentions

    ServerAdmin [email protected]
    DocumentRoot /home/ak93450/public_html
    BytesLog domlogs/
    User ak93450
    Group ak93450
    <IfModule mod_php4.c>
    php_admin_value open_basedir "/home/ak93450/:/usr/lib/php:/usr/local/lib/php:/tmp"
    <IfModule mod_php5.c>
    php_admin_value open_basedir "/home/ak93450/:/usr/lib/php:/usr/local/lib/php:/tmp"
    <IfModule mod_userdir.c>
    UserDir disabled
    UserDir enabled ak93450
    UserDir public_html

    User ak93450
    Group ak93450

    SSLCertificateFile /usr/share/ssl/certs/
    SSLCertificateKeyFile /usr/share/ssl/private/
    SSLLogFile /usr/local/apache/domlogs/
    CustomLog /usr/local/apache/domlogs/ combined
    SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
    BytesLog /usr/local/apache/domlogs/

    SSLEnable is 1194

  3. #3
    My first guess would be that you have SSL enabled without having complied and configured mod_ssl. If you recently recompiled apache...and this looks like a cpanel configured apache file, redo the configuration with mod_ssl
    *AlphaOmegaHosting.Com* - Hosting since 1998
    Managed Dedicated Servers and VPS
    Hosted Exchange 2010 Email Service

  4. #4
    it is cpanel

    Where is mod ssl in easyapache? I do not see that option

  5. #5
    Check your httpd.conf for this to make sure it's there

    <IfDefine SSL>
    AddModule mod_ssl.c

    Is the virtual host entry wrapped in <IfDefine SSL> and </IfDefine SSL>?

  6. #6
    I added them

    I did

    service httpd stop
    service httpd startssl

    They still do not show up as 443 secured in whm > list accounts

    [email protected] [/usr/local/apache/conf]# /usr/local/apache/bin/apachectl configtest
    Syntax OK

    [email protected] [/usr/local/apache/conf]# service httpd stop
    /etc/init.d/httpd stop: httpd stopped

    [email protected] [/usr/local/apache/conf]# service httpd startssl
    /etc/init.d/httpd startssl: httpd started

  7. #7
    Join Date
    Sep 2000
    Alberta, Canada
    Sounds like there is more here than meets the eye.

    Presuming things were working fine before, what changed to cause the error in the first place? Sounds like an SSL Cert gone bad. And I say that because the information provided for the VirtualHost entry is totally wrong.

    You should have your DC look into the situation or hire someone to do it for you. Odds are, changes need to be made in more than one place to resolve the issue. - for all your Hosting needs
    Helping people Host, Create and Maintain their Web Site
    ServerAdmin Services also available

  8. #8
    Quote Originally Posted by Website Rob
    And I say that because the information provided for the VirtualHost entry is totally wrong.
    In what way is it totally wrong? It looks like any other virtual host entry where a cert has been installed.

    TBCS: when you say you "added them", do you mean you added the wrap around the virtual host entry, or you also added the IfModule item for mod_ssl, or both?

    Since your apache configtest passed and apache restarted, did you try to go to the site by https://? You say it doesn't appear as IP:443 in the list accounts option in cPanel - did you give the site its own IP, or is still showing up as the shared IP with all the other sites?

    If the site works with https://, then personally I'd ignore whatever is in cPanel for now, because all you really want to know is that the cert is installed and working.

  9. #9
    cpanel is the one that corrupted all this (as usual).

    These 8 domains always had ssl installed to them for a long time. They always had their own IP's obviousy.

    I only added the ifmodule as cpanel brainlessly removed them.

  10. #10
    Join Date
    Jul 2003
    Goleta, CA
    what version of apache are you running?

    * nevermind I was thinking of edge build

    run /scripts/easyapache in an ssh session.
    select option 7
    ssl support is after phpsuexec or close to it.
    Patron: I'd like my free lunch please.
    Cafe Manager: Free lunch? Did you read the fine print stating it was an April Fool's joke.
    Patron: I read the same way I listen, I ignore the parts I don't agree with. I'm suing you for false advertising.
    Cafe Owner: Is our lawyer still working pro bono?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts