Results 1 to 6 of 6
  1. #1
    Join Date
    Aug 2006
    Location
    Canada
    Posts
    287

    change default port80

    I want to change the defualt port for my site from 80 into **** .... I know to change the port for individual sites....
    but I want to make this port enable or assgin for default site from IIS6... so when I will create site it automatically create under new port....

    Any advise ?

  2. #2
    **Start Regedt32.exe HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ServiceProvider\ServiceType\W3SVC
    ** In tcp Port value
    **The DWORD Editor dialog box should appear with the default value (0x50 Hex; 80 Decimal) listed. Change the decimal value to the number of the port that you want the World Wide Web Publishing Service to listen to.
    **Restart IIS
    Live Your DreamZ
    ~Besty

  3. #3
    Join Date
    Aug 2006
    Location
    Canada
    Posts
    287
    I have tried exactly what you said Besty... but it didn't change anything
    I am trying to give port 8080
    when I gave this it also change the hexi value to 1f90
    then I restart IIS.. nothing work


    Quote Originally Posted by besty
    **Start Regedt32.exe HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ServiceProvider\ServiceType\W3SVC
    ** In tcp Port value
    **The DWORD Editor dialog box should appear with the default value (0x50 Hex; 80 Decimal) listed. Change the decimal value to the number of the port that you want the World Wide Web Publishing Service to listen to.
    **Restart IIS

  4. #4
    Check by rebooting the server..
    Live Your DreamZ
    ~Besty

  5. #5
    Join Date
    Aug 2002
    Location
    Denver, CO
    Posts
    331
    Try configuring the server itself with IIS MMC. Instead of right clicking on the specific site and configing the site's IP address, try the following...

    Right Click "Web Sites" (yes the folder itself, don't drill down)
    Change the TCP port here!

    This should change the default for all sites in IIS. Although any sites created before this might still be different! In theory I think any site that has any value changed from the default (inherited from "Web Sites") will use that specified change. However, I think any site without that "master" setting or whatever you call it - will inherit the default values. At the very least, any new sites should inherit the default.

    [reread: sorry, the above is confusing - but I think it makes sense. if not skip to the following]

    So try changing this setting and then creating a new site. Might work from my initial thoughts. (Though I really don’t want to test changing this myself due to messing up my own current settings!)
    Last edited by Rebies; 09-01-2006 at 02:32 AM.

  6. #6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •