Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2006
    Posts
    38

    aptitude problem with broken package

    Linux OS: Debian 3.1

    I have a new Debian VPS. I just reinstalled the VPS, and without having done anything to the system, aptitude says I have a broken package. And I can't seem to fix it.

    I start aptitude. Do u to update. Then U to prepare to upgrade. The top banner then displays #Broken: 1

    I do / to search and enter ~b to look for broken packages. Sendmail-bin is broken because:
    sendmail-bin depends on libsasl2 (>= 2.1.19.dfsg1) [UNAVAILABLE]

    I search on libsasl2 and the version installed is 2.1.19-1.5sarge.

    I went to http://packages.debian.org and searched on sendmail-bin. It says that sendmail-bin depends on:

    libsasl2 (>= 2.1.19) [amd64, mipsel, powerpc]
    Authentication abstraction library
    libsasl2 (>= 2.1.19.dfsg1) [not amd64, mipsel, powerpc]

    Can someone suggest what the problem is? Did my ISP set me up with a broken package because they put the wrong libsasl2 on the VPS?

  2. #2
    Join Date
    Jul 2006
    Posts
    84
    Are you sure you want sendmail? There are easier to use options.

    U will just update your package list. G will install the upgrades.

    For now it might be less confusing to just use apt-get

    what happens if you just do this?
    $ apt-get update
    $ apt-get upgade

    Some more commands to try:

    $apt-cache unmet
    will give you a list of unmet dependencies.

    $ apt-cache depends <packagename>
    shows the the dependency info for that package

    $ apt-get check
    another way of checking unmet dependencies

    also, make sure you have the following (or mirrors) in /etc/apt/sources list

    deb http://http.us.debian.org/debian stable main contrib non-free
    deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

    deb http://security.debian.org stable/updates main

    deb-src http://http.us.debian.org/debian stable main contrib non-free
    deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

  3. #3
    Join Date
    Jul 2006
    Posts
    38
    Are you sure you want sendmail? There are easier to use options.
    Thanks for the reply. Yes, I actually want postfix eventually not sendmail.

    U will just update your package list. G will install the upgrades.
    If I try to do 'g' (after doing 'u'), aptitude says:

    No Packages will be installed, removed or upgrade. Some packages could be upgraded, but you have chosen not to upgrade them. Type "U" to prepare an upgrade.

    When I do "U" (uppercase), I get "#Broken: 1".

    For now it might be less confusing to just use apt-get
    I wanted to use aptitude because it remembers dependencies.
    If I install A, and B is installed as a required dependency, then when I remove A, B will automatically be removed, too. As I understand it, apt-get won't automatically removed B when A is removed.

    apt hasn't been able to resolve the broken dependency problem, either.

    what happens if you just do this?
    $ apt-get update
    $ apt-get upgade
    I previously did do update and upgrade using aptitude to upgrade the system. So when I do
    apt-get update
    apt-get upgrade
    it tells me that sendmail-bin "has been held back". And that "0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded." The "1 not up upgraded" is obviously sendmail-bin.

    $apt-cache unmet
    will give you a list of unmet dependencies.
    It shows that sendmail-bin "has an unmet dep:
    depends: libsasl2 (>= 2.1.19.dfsg1)". So it detects the same problem as aptitude did.

    $ apt-cache depends <packagename>
    shows the the dependency info for that package
    This shows libsasl2 as a dependency of sendmail-bin.

    I did change my sources.list to match what you posted. I did 'u', but the broken dependency reappears when I do 'U' (uppercase) in aptitude, or if I do
    apt-get upgrade
    it still says that sendmail-bin "has been kept back".

  4. #4
    Join Date
    Jul 2006
    Posts
    84
    Two more things to try:

    $ apt-get dselect-upgrde (in case packages are "stuck" in the upgrade queue thing)

    $ apt-get dist-upgrade (this is distrobution upgrade. Probobly not your problem. It's usualy just for kernel upgrades and major stuff like that.)

    Aptitude will track packages added by other means. All you have to do is start it and then quit and it will ask if you want to remove the uneeded packages before you quit.

    Are you getting any updates from security.debian.org?

    What sendmail do you have installed? The current security release is 8.13.4-3sarge2. Is that what you have? If not, you need to upgrade your sendmail.

  5. #5
    Join Date
    Jul 2006
    Posts
    38
    Elivs,

    Thanks.
    I decided to just get rid of sendmail-bin
    apt-get remove sendmail-bin
    since I plan to install postfix. Since I got rid of it, it haven't had any more aptitude headaches.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •