Results 1 to 6 of 6
  1. #1
    Join Date
    Apr 2006
    Location
    Jacksonville, FL
    Posts
    498

    403 Errors on Addon Domain

    Hey guys,

    I've got an account that is coming up with 403 error messages when trying to access some addon domains on the account.

    http://on-viagra.com is the domain, which loads the 403 message.

    However, you can type in http://on-viagra.com/index.html and it loads just fine.

    I checked permissions on the directory /public_html/on-viagra, and everything seems ok with 755.

    .htaccess is blank.

    Any ideas?

    Kyle

  2. #2
    Join Date
    Nov 2004
    Location
    Northamptonshire
    Posts
    56
    403 is a really a blanket error covering many things. The only real way to find the fault is to look in the apache error log. You should be able to request this from your hosting company.
    Andrew Hutchings (A-Wing) - Linux Jedi
    A-Wing Internet Services
    Windows is the path to the darkside...Windows leads to Blue Screen. Blue Screen leads to downtime. Downtime leads to suffering...I sense much Windows in you.

  3. #3
    Join Date
    Jun 2003
    Location
    World Wide Web
    Posts
    581
    As per the error you are getting on http://on-viagra.com/, the issue looks to be a permission error on the root directory for the addon domain.
    Please make sure the permissions as well as the ownership for the root folder(DocumentRoot) for the addon domain are correct.

    Also, this could be a problem with the configuration of the httpd.conf file on your server.

    You would need to check the apache error logs(as A-Wing suggested) to check what is happening, as you will get more valuable information there...
    SupportExpertz.com - the name says it all!
    Managed Cloud Servers
    Server Management and Monitoring
    24x7 outsourced customer support

  4. #4
    Join Date
    Apr 2006
    Location
    Jacksonville, FL
    Posts
    498
    I've found the following in the error log:

    [Mon Aug 28 22:43:44 2006] [error] [client 81.177.15.43] script not found or unable to stat: /home/anything/public_html/on-viagra/index.php
    [Mon Aug 28 22:43:44 2006] [error] [client 81.177.15.43] Directory index forbidden by rule: /home/anything/public_html/on-viagra/
    [Mon Aug 28 22:41:50 2006] [error] [client 65.54.188.133] script not found or unable to stat: /home/anything/public_html/on-viagra/index.php
    [Mon Aug 28 22:41:50 2006] [error] [client 65.54.188.133] Directory index forbidden by rule: /home/anything/public_html/on-viagra/drugs/
    [Mon Aug 28 22:40:52 2006] [error] [client 69.248.0.118] script not found or unable to stat: /home/anything/public_html/on-viagra/index.php
    Not sure why it is reporting a index.php, since I don't see one in that directory-- only index.html.

  5. #5
    Join Date
    Apr 2006
    Location
    Jacksonville, FL
    Posts
    498
    Fixed it.

    The problem had to do something with something in the .htaccess in the public_html directory.

    #################################################
    ## PHP Link Directory - Apache Server Settings ##
    #################################################

    # Protect files
    <Files ~ "^(.*)\.(inc|inc\.php|tpl|sql)$">
    Order deny,allow
    Deny from all
    </Files>

    # Protect directories
    <Files ~ "^(backup|files|images|include|lang|libs(/.+)?|temp(/.+)?|templates(/.+)?|javascripts(/.+)?)$">
    Order deny,allow
    Deny from all
    </Files>

    # Disable directory browsing
    Options -Indexes

    # Follow symbolic links in this directory
    Options +FollowSymLinks

    # Override PHP settings that cannot be changed at runtime
    # (If your server supports PHP settings via htaccess you can comment following two lines off)
    # php_value register_globals 0
    # php_value session.auto_start 0

    # Customized error messages
    # ( If you are running in a subfolder please add it, example: "directory/index.php?httpstatus=404" )
    ErrorDocument 404 index.php?httpstatus=404

    # Set the default handler
    DirectoryIndex index.php

    # URL rewrite rules
    <IfModule mod_rewrite.c>
    RewriteEngine On

    ## Details Link Page Rewrite##
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    RewriteRule (.*)detail/link-(.*).htm[l]?$ detail.php [QSA,NC]

    ## Pagination Rewrite
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    RewriteRule (.*)page-(\d+)\.htm[l]?(.*)$ $1/?p=$2 [PT,NC]

    ## Category redirect
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_FILENAME} !-l
    RewriteRule ^(.*)$ index.php [QSA,L]

    </IfModule>

  6. #6
    Join Date
    Jun 2003
    Location
    World Wide Web
    Posts
    581
    The ' DirectoryIndex' set in .htaccess was the problem
    -------------------------------------------
    # Set the default handler
    DirectoryIndex index.php
    -------------------------------------------
    This had only 'index.php' as the default handler, so other index files such as index.html or index.htm would not have come up on taking the site.

    Directory browsing was also disabled in the .htaccess, thats why you got a forbidden error(when index.php was not found).
    -------------------------------------------
    # Disable directory browsing
    Options -Indexes
    -------------------------------------------


    You just need to add the index file that you want to the ' DirectoryIndex' list in .htaccess. For example:
    -------------------------------------------
    # Set the default handler
    DirectoryIndex index.html index.php
    -------------------------------------------
    SupportExpertz.com - the name says it all!
    Managed Cloud Servers
    Server Management and Monitoring
    24x7 outsourced customer support

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •