Results 1 to 5 of 5
  1. #1
    Join Date
    Jul 2006
    Posts
    232

    trouble installing yum on virtuozzo vps

    [root@user ~]# rpm -ihv http://mirrors.kernel.org/centos/4.3...os4.noarch.rpm
    Retrieving http://mirrors.kernel.org/centos/4.3...os4.noarch.rpm
    warning: /var/tmp/rpm-xfer.y7tP3T: V3 DSA signature: NOKEY, key ID 443e1821
    error: Failed dependencies:
    yumconf is needed by yum-2.4.2-2.centos4.noarch

    [root@user ~]# rpm -Uhv yum*
    warning: yum-2.4.2-2.centos4.noarch.rpm: V3 DSA signature: NOKEY, key ID 443e1821
    error: Failed dependencies:
    yumconf is needed by yum-2.4.2-2.centos4.noarch
    [root@user ~]# rpm -q yum centos-yumconf
    package yum is not installed
    package centos-yumconf is not installed

    Can someone please explain how to simply install yum on centos 4.3 vps?

    This used to work on 3.7 without a problem (even 4.3 before!)
    rpm -vi ftp://mirrors.kernel.org/centos/3.6/...s.7.noarch.rpm

    The above suddenly gives errors:

    [root@user ~]# rpm -vi ftp://mirrors.kernel.org/centos/3.6/...s.7.noarch.rpm
    Retrieving ftp://mirrors.kernel.org/centos/3.6/...s.7.noarch.rpm
    error: skipping ftp://mirrors.kernel.org/centos/3.6/...s.7.noarch.rpm - transfer failed - Unknown or unexpected error

  2. #2
    Join Date
    Jul 2006
    Posts
    232

  3. #3
    Join Date
    Aug 2005
    Location
    Maidenhead, UK
    Posts
    329
    if your host is using OpenVZ, just ask them to install yum onto your server, its dead easy i doubt they would have a problem

    or try installing the yum conf first as its a dependancy file links as follows
    Code:
    http://isoredirect.centos.org/centos/4/os/i386/CentOS/RPMS/centos-yumconf-4-4.5.noarch.rpm 
    
    http://isoredirect.centos.org/centos/4/os/i386/CentOS/RPMS/yum-2.4.2-2.centos4.noarch.rpm
    there may be other dependancies to look out for aswell

  4. #4
    Join Date
    Jul 2006
    Posts
    232
    On the same vps I have a strange issue with APF

    [root@user]# apf -r
    eth0: error fetching interface information: Device not found
    eth0: error fetching interface information: Device not found
    eth0: error fetching interface information: Device not found
    eth0: error fetching interface information: Device not found
    eth0: error fetching interface information: Device not found
    Unable to load iptables module (ip_tables), aborting.


    I am unable to start APF. I did restart iptables just fine.

    Any help appreciated

    APF conf is correct also:

    SET_VNET="0"
    SET_MONOKERN="1"
    Last edited by NoAgendas; 07-28-2006 at 05:19 PM.

  5. #5
    Try to change IFACE_IN and IFACE_OUT from "eth0" to "venet0"
    KnownHost Linux VPS Specialists
    Toll Free: (866)-785-5479
    www.knownhost.com sales@knownhost.com

    New look & New plans!

  6. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •