hosted by liquidweb


Go Back   Web Hosting Talk : Web Hosting Main Forums : Hosting Security and Technology : cpanel auto-responders stopped working
Reply

Forum Jump

cpanel auto-responders stopped working

Reply Post New Thread In Hosting Security and Technology Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old 05-23-2006, 04:14 PM
UnrealSilence UnrealSilence is offline
Disabled
 
Join Date: Jan 2006
Posts: 907

cpanel auto-responders stopped working


I checked /etc/valiases/domain and see all the proper .autorespond extensions/lines

The auto-responders however are not working at all, no responses made well automatically

I ran forced cpanel update and restart exim as well

Any suggestions? DNS is fine.

The mails were sent fine, no errors returned and nothing in mail queue.
Just the auto responders stopped working.

I got 2 clients both on 2 seperate cpanel servers (both using RELEASE) that submitted
a ticket about this problem.


Last edited by UnrealSilence; 05-23-2006 at 04:28 PM.
Reply With Quote


Sponsored Links
  #2  
Old 05-24-2006, 12:38 PM
UnrealSilence UnrealSilence is offline
Disabled
 
Join Date: Jan 2006
Posts: 907
Hmm...anyone know about this or have similiar issue in the past?

I can't figure this out for the life of me.

Reply With Quote
  #3  
Old 05-24-2006, 01:53 PM
supportexpertz supportexpertz is offline
Web Hosting Master
 
Join Date: Jun 2003
Location: World Wide Web
Posts: 581
You might want to check if the autoresponder file is present under /home/username/.autorespond/
Also make sure that /usr/local/cpanel/bin/autorespond is working and has the correct permissions.

__________________
SupportExpertz.com - the name says it all!
Managed Cloud Servers
Server Management and Monitoring
24x7 outsourced customer support


Reply With Quote
Sponsored Links
  #4  
Old 05-24-2006, 02:49 PM
UnrealSilence UnrealSilence is offline
Disabled
 
Join Date: Jan 2006
Posts: 907
yes,

Code:
root@server2 [/home/patri3]# ls -lh
total 124K
drwx--x--x   16 patri3 patri3 4.0K May 24 13:36 ./
drwx--x--x  606 root   root    20K May 23 18:49 ../
drwx------    2 patri3 patri3 4.0K May 23 15:11 .autorespond/
-rw-------    1 patri3 patri3  478 May 24 13:36 .autorespond-loopprotect
Code:
root@server2 [/usr/local/cpanel/bin]# ls -lh
total 60M
drwxr-xr-x   2 root     root      12K May 23 15:07 ./
drwx--x--x  37 root     wheel    4.0K May 23 15:07 ../
lrwxrwxrwx   1 root     wheel      16 Jan 29 00:42 adduser -> /scripts/adduser*
-rwxr-xr-x   1 root     root      942 Jun 17  2005 antirelaydinstall*
-rwx------   1 root     root     2.4M May 14 20:04 apacheadmin*
lrwxrwxrwx   1 root     root        6 Jan 29 00:42 apachewrap -> cpwrap*
-rwxr-xr-x   1 root     root     612K May 14 20:04 autorespond*

Reply With Quote
  #5  
Old 05-24-2006, 03:26 PM
supportexpertz supportexpertz is offline
Web Hosting Master
 
Join Date: Jun 2003
Location: World Wide Web
Posts: 581
The files within /home/username/.autorespond/* should have the same owner and chmod 644.
If that is correct, try checking the logs(/var/log/exim_mainlog) and see what haapens when you send the mail. If the autoresponder is working, you should see something like the following:

1Fhkdj-0004j8-TK => |/usr/local/cpanel/bin/autorespond user@domain /home/username/.autorespond (user@domain) <user@domain> R=virtual_aliases_nostar T=virtual_address_pipe S=1808 QT=4s DT=0s

If its broken, you may see something like the following:
1Fhkdj-0004j8-TK** |/usr/local/cpanel/bin/autorespond user@domain /home/username/.autorespond (user@domain) <user@domain> R=virtual_aliases_nostar T=virtual_address_pipe: delivery to pipe forbidden


Also check if the pipe_transport option is enabled in the exim configuration. You can also try a force exim upgrade(after taking a backup of /etc/exim.conf).

__________________
SupportExpertz.com - the name says it all!
Managed Cloud Servers
Server Management and Monitoring
24x7 outsourced customer support


Reply With Quote
  #6  
Old 05-24-2006, 03:38 PM
UnrealSilence UnrealSilence is offline
Disabled
 
Join Date: Jan 2006
Posts: 907
Thanks for your reply.

Exim mainlog shows this error: (many of them)

2006-05-24 06:39:39 H=(duitsreclame.nl) [xxx.207.56.229] F=<roarko@recipient.nl> temporarily rejected RCPT <subscribe@hosteddomain.com>: error in redirect data: colon expected after route list in "@hostedomain.com,|/usr/local/cpanel/bin/autorespond subscribe@hostedomain.com /home/patri3/.autorespond"


So what exactly does that mean now?

Reply With Quote
Reply

Related posts from TheWhir.com
Title Type Date Posted
What's New at cPanel: IPv6 and 1:1 NAT Support Web Hosting News 2013-10-01 18:12:07
cPanel & WHM Software 11.36 Reaches Stable Tier Status Web Hosting News 2013-04-09 11:44:33
Hosting Control Panel cPanel & WHM 11.34 Release Hits Stable Tier Web Hosting News 2012-11-12 17:04:57
cPanel Conference 2012: Virtualize All the Things with Nate Custer Web Hosting News 2012-11-12 13:54:36
Video: Hosting Control Panel cPanel, and Billing Software WHMCS Discuss Investment, Partnership, Integration Whir Tv 2014-05-02 15:25:56


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
Advertisement:
Web Hosting News:



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?