Results 1 to 4 of 4
  1. #1
    Join Date
    Nov 2001

    * How to stop hostname showing in ftp?

    I have got a big problem. My resellers as they sell for more than us, we give them their own ip's for nameservers and tell them to set up a catchall email address so that their customers can't see who we are but now we have got another problem the writing that comes up when you connect to ftp says our hostname. I tried renaming it to something anonimous like but the email stopps working when I do this !
    So is there a way to change the text so that it doesn't show our hostname?? And if not, is there a way to change the hostname to somthig that doesn't exist without stopping the email from working????

    Please help it is urgent !!!


  2. #2
    Join Date
    Sep 2001

    The hostname is a serious thing and it is what identifies your server - so dont go changing it. Also if you need Apache to start your hostname should resolve to your server IP - which means you need zone records for your hostname in your DNS

    If your domain is and you want to call your server and your server's primary IP is then you need an A record in your DNS that resolves to

    If you are using ProFTPd then you can edit proftpd.conf and set

    ServerIdent Off [or No cant remember] and your hostname wont show in FTP

    Offering Managed Servers - for an exclusive clientèle who value uptime, caring support and superior technology.

  3. #3
    Join Date
    Nov 2001
    thanks I've just tried serverident off and it removes the PROFTP thing but still says :

    < 220 FTP server ready.

    I have read on that you can specify the message and put for example :

    ServerIndent "Ftp server ready"
    to not show the hostname but I've tried this and I can't connect to ftp afterwards !
    any ideas?

  4. #4
    Join Date
    Nov 2001
    ANy thanks, I've found the solution and fixed it :
    The is the code you are supposed to use :

    ServerIdent on "Ftp server ready"

    You just put it at the bottom of the proftpd.conf file which is in /usr/local/psa/ftpd/etc/

    I hope this helps anyone with the same problem as me


  5. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts