hosted by liquidweb


Go Back   Web Hosting Talk : Web Hosting Main Forums : Hosting Security and Technology : Symlinks
Reply

Forum Jump

Symlinks

Reply Post New Thread In Hosting Security and Technology Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old 05-15-2002, 01:11 AM
iamdave iamdave is offline
Web Hosting Master
 
Join Date: Nov 2001
Location: California
Posts: 1,991

Symlinks


I did this
Code:
ln -s /usr/local/psa/home/vhosts/domain.com/httpdocs /usr/local/psa/home/vhosts/domain.com/httpsdocs
It placed the symlink, however when I click on it, it doesn't take me to the httpdocs directory. Anyone know why?

Reply With Quote


Sponsored Links
  #2  
Old 05-15-2002, 03:27 AM
Starhost Starhost is offline
Web Hosting Evangelist
 
Join Date: Nov 2000
Posts: 486
You have done it wrong if I'm correct.

Suppose you want a symlink in the directory
/home/admin/web to /var/log/admin/

then do the folowing:

ln -s /home/admin/web/sym_link_name /var/log/admin/

Reply With Quote
  #3  
Old 05-15-2002, 08:20 PM
iamdave iamdave is offline
Web Hosting Master
 
Join Date: Nov 2001
Location: California
Posts: 1,991
For some reason it is not working.

Reply With Quote
Sponsored Links
  #4  
Old 05-15-2002, 08:41 PM
Gadgy Gadgy is offline
WHT Addict
 
Join Date: Apr 2002
Posts: 165
this is a real daft question, but your dir ends in domain.com/httpdocs ???

- if this is a server docs dir have you made sure symlinks is enabled if it needs to be and that overrides etc are appropriately set to allow it to be enabled for the v server in question? just a guess, probibly wrong.

Reply With Quote
  #5  
Old 05-15-2002, 08:56 PM
iamdave iamdave is offline
Web Hosting Master
 
Join Date: Nov 2001
Location: California
Posts: 1,991
Quote:
Originally posted by Gadgy
this is a real daft question, but your dir ends in domain.com/httpdocs ???

- if this is a server docs dir have you made sure symlinks is enabled if it needs to be and that overrides etc are appropriately set to allow it to be enabled for the v server in question? just a guess, probibly wrong.
I use plesk. Plesk keeps a directory sturcute this way:

Domain
> httpdcos
> httpsdocs
> cgi-bin
> etc...
Symlinks are enabled because it is putting in the shortcut, but the shortcut doesn't work.

Reply With Quote
  #6  
Old 05-15-2002, 09:05 PM
Gadgy Gadgy is offline
WHT Addict
 
Join Date: Apr 2002
Posts: 165
Ah, I see, not familiar with Plesk. I normaly am using Webmin. Sorry.

Reply With Quote
Reply

Related posts from TheWhir.com
Title Type Date Posted


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
Advertisement:
Web Hosting News:



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?