hosted by liquidweb


Go Back   Web Hosting Talk : Web Hosting Main Forums : Hosting Security and Technology : Force full duplex, this how?
Reply

Forum Jump

Force full duplex, this how?

Reply Post New Thread In Hosting Security and Technology Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old
Local tech for Los Angeles
 
Join Date: Feb 2003
Location: North Hollywood, CA
Posts: 2,541

Force full duplex, this how?


ifcfg-eth0

ETHTOOL_OPTS="speed 100 duplex full autoneg off"

then restart the network?

For some reason i totally forgot.. I'm getting some slow speeds on a Cisco 2900 switch (on the switch).

-dmesg-
Code:
eth0: network connection up using port A
    speed:           100
    autonegotiation: yes
    duplex mode:     half
    flowctrl:        none
    irq moderation:  disabled
    scatter-gather:  enabled
thx

__________________
Remote Hands and Your Local Tech for the Los Angeles area.

(310) 573-8050 - LinkedIn




Sponsored Links
  #2  
Old
Local tech for Los Angeles
 
Join Date: Feb 2003
Location: North Hollywood, CA
Posts: 2,541
hmm well that didn't work..

I did a full reboot dmesg shows the same, any ideas?

logs say this..

Code:
Dec 23 07:56:43 webby ifup: Cannot get current device settings: Operation not supported 
Dec 23 07:56:43 webby ifup:   not setting speed 
Dec 23 07:56:43 webby ifup:   not setting duplex 
Dec 23 07:56:43 webby ifup:   not setting autoneg
is it the switch?

MotherBoard Asus P4P-800-E Deluxe

__________________
Remote Hands and Your Local Tech for the Los Angeles area.

(310) 573-8050 - LinkedIn



Last edited by Jeremy; 12-23-2005 at 03:00 PM.
  #3  
Old
Telecommunication operator
 
Join Date: May 2002
Location: Russia, Moscow
Posts: 1,482
on linux you can use mii-tools as i remember for check what happen with your nic (include his capabilities)

__________________
Rustelekom LLC Dedicated server since 2002, RIPE NCC member, LIR, AS51168

Sponsored Links
  #4  
Old
Disabled
 
Join Date: Dec 2004
Posts: 227
You can either as someone suggested use mii-tool

# mii-tool

No opitions, tells you the status of the link

# mii-tool eth0 -F 100baseTx-FD

will force 100Mb Full Duplex .. won't always work though

# mii-tool eth0 -A 100baseTx

Will advertise both full and half duplex. If your switch link is locked at half duplex, then you need to make the switch port full duplex as well.

You can use ethtool from command line too

# ethtool -s eth0 speed 100 duplex full autoneg off

or

# ethtool eth0

to see the supported options, no need to restart the network when changing the interface via mii-tool or ethtool.

# mii-tool

Will tell you where you are at and where you finish up.


Last edited by DigitalN; 12-23-2005 at 09:59 PM.
  #5  
Old
Web Hosting Master
 
Join Date: Feb 2003
Location: Detroit
Posts: 816
Both ends of the connection need to have the same setting. Set the switch to 100/full first then the machine. most of the time, auto does work well. If your switch is not set to auto right now try that first.

__________________
ManagedWay - Hosting your business in the cloud!
Managed hosting and colocation with geographic redundant data centers in Detroit and Grand Rapids.

  #6  
Old
Predatory Poster
 
Join Date: Jul 2003
Location: Goleta, CA
Posts: 5,550
Auto negotiate can cause a lot of problems though. I agree with setting both sides as the above poster stated.

__________________
Patron: I'd like my free lunch please.
Cafe Manager: Free lunch? Did you read the fine print stating it was an April Fool's joke.
Patron: I read the same way I listen, I ignore the parts I don't agree with. I'm suing you for false advertising.
Cafe Owner: Is our lawyer still working pro bono?

  #7  
Old
Web Hosting Master
 
Join Date: Feb 2003
Location: Detroit
Posts: 816
Quote:
Originally Posted by pixelized
Auto negotiate can cause a lot of problems though. I agree with setting both sides as the above poster stated.
Setting both sides also applies to 'auto'. most of the problems with using auto negotiate that I have seen is one side was not set the same.

You have a machine set to auto and the switch set to 100/full you may have problems.

__________________
ManagedWay - Hosting your business in the cloud!
Managed hosting and colocation with geographic redundant data centers in Detroit and Grand Rapids.

  #8  
Old
Disabled
 
Join Date: Dec 2004
Posts: 227
The problems I have seen setting network connection parameters with mii-tool has been due to a crappy switch, that advertises either half or full duplex.. no autoneg

In these cases, ethtool saves the day by making your interface not try to autonegotiate. (mii-tool does not work in these cases I find)

So imho, you really need to look at your switch first, as that is likely the cause of the problem.

  #9  
Old
Local tech for Los Angeles
 
Join Date: Feb 2003
Location: North Hollywood, CA
Posts: 2,541
Hmmm the ports are forced 100mbps/fd.

i still get the error

Code:
Dec 23 07:56:43 webby ifup: Cannot get current device settings: Operation not supported 
Dec 23 07:56:43 webby ifup:   not setting speed 
Dec 23 07:56:43 webby ifup:   not setting duplex 
Dec 23 07:56:43 webby ifup:   not setting autoneg

__________________
Remote Hands and Your Local Tech for the Los Angeles area.

(310) 573-8050 - LinkedIn


  #10  
Old
Disabled
 
Join Date: Dec 2004
Posts: 227
What does

# mii-tool

reveal?

What is your switch set to?

  #11  
Old
Local tech for Los Angeles
 
Join Date: Feb 2003
Location: North Hollywood, CA
Posts: 2,541
Code:
[root@webby ~]# mii-tool eth0
SIOCGMIIPHY on 'eth0' failed: Bad address
also trying doesnt work

Code:
[root@webby ~]# mii-tool -F 100baseTx-FD eth0
SIOCGMIIPHY on 'eth0' failed: Bad address
NIC - Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller

my route table looks fine, i can shell in and out of it.

__________________
Remote Hands and Your Local Tech for the Los Angeles area.

(310) 573-8050 - LinkedIn


  #12  
Old
Local tech for Los Angeles
 
Join Date: Feb 2003
Location: North Hollywood, CA
Posts: 2,541
Thank you all for your help so far.

on the switch the command
Code:
show run
out puts this:

Code:
 interface FastEthernet0/9
 description LAX09-DM
 duplex full
 speed 100
 switchport access vlan 30
 spanning-tree portfast
dmesg

Code:
eth0: network connection up using port A
 speed:           100
 autonegotiation: yes
 duplex mode:     half
 flowctrl:        none
 irq moderation:  disabled
 scatter-gather:  enabled

-------

 divert: allocating divert_blk for eth0
 eth0: Yukon Gigabit Ethernet 10/100/1000Base-T Adapter
 PrefPort:A  RlmtMode:Check Link State
mii-tool - out puts

Code:
[root@webby ~]# mii-tool
SIOCGMIIPHY on 'eth0' failed: Bad address
no MII interfaces found

__________________
Remote Hands and Your Local Tech for the Los Angeles area.

(310) 573-8050 - LinkedIn


  #13  
Old
Disabled
 
Join Date: Dec 2004
Posts: 227
Try

# ethtool -s eth0 speed 100 duplex full autoneg off

Does that work for you?

Failing that, I would look at changing the switch port and then the network card interface.

  #14  
Old
Local tech for Los Angeles
 
Join Date: Feb 2003
Location: North Hollywood, CA
Posts: 2,541
Code:
[root@webby ~]# ethtool -s eth0 speed 100 duplex full autoneg off
Cannot get current device settings: Operation not supported
  not setting speed
  not setting duplex
  not setting autoneg
O no...

__________________
Remote Hands and Your Local Tech for the Los Angeles area.

(310) 573-8050 - LinkedIn


  #15  
Old
Disabled
 
Join Date: Dec 2004
Posts: 227
It might be best to try setting your switch to 'autonegotiate' rather than forcing full duplex, then set the interface to 'autonegotiate' too.

Try another network card if all fails, looks like your card doesn't want to be played around with, maybe a driver issue or just the card won't take the changes.
I'd try autonegotiate both ends, different switch port, then try another nic card.

Reply

Related posts from TheWhir.com
Title Type Date Posted
Microsoft Issues Patch for Critical Vulnerability Affecting Windows Systems Web Hosting News 2014-11-14 13:30:39
US Navy Launches Cybersecurity Task Force to Address Fragmented Systems Web Hosting News 2014-11-05 12:02:48
Fortinet Updates DDoS Attack Mitigation Solution for New Threats Web Hosting News 2014-03-10 17:05:52
IPv4 Addresses to be Depleted by December 2014: Infographic Blog 2014-02-10 12:27:18
Incapsula Program Helps Web Hosts Protect Against Brute Force WordPress Attacks Web Hosting News 2013-04-17 12:13:49


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
WHT Host Brief Email:

We respect your privacy. We will never sell, rent, or give away your address to any outside party, ever.

Advertisement:
Web Hosting News:
WHT Membership
WHT Membership



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?