hosted by liquidweb


Go Back   Web Hosting Talk : Web Hosting Main Forums : Hosting Security and Technology : Apache (httpd) Fails!
Reply

Forum Jump

Apache (httpd) Fails!

Reply Post New Thread In Hosting Security and Technology Subscription
 
Send news tip View All Posts Thread Tools Search this Thread Display Modes
  #1  
Old 12-18-2005, 08:35 PM
funmaza funmaza is offline
Junior Guru Wannabe
 
Join Date: May 2005
Location: Pakistan
Posts: 73
*

Apache (httpd) Fails!


Hi,

I am really tensed about the problem of Apache Failure very frequently, whenever there are 150 Connections being processed and CPU Load 1-1.5, Apache (httpd) restarts...

I am on 2.4 Celeron Processor with 512 RAM , and hosting some downloadable content which is highly downloaded at every moment... so anyone have any idea that why httpd restarts so frequently even after 30 mins when connections are 150...

Also (For an Idea) the Bandwidth consumption is also such that in 1 hour 1 GB data is being downloaded. So, because i have never experience such issue so don't have any idea on this...


Reply With Quote


Sponsored Links
  #2  
Old 12-18-2005, 08:41 PM
layer0 layer0 is offline
Performance Specialist
 
Join Date: Dec 2004
Location: New York, NY
Posts: 10,454
Try increasing MaxClients in httpd.conf.

Assuming your using the default config, you can simply run this shell command:

replace "MaxClients 150" "MaxClients 300" -- /usr/local/apache/conf/httpd.conf;service httpd restart

Let me know how it goes

__________________
MediaLayer, LLC - www.medialayer.com Lightning fast web hosting since 2005.
The pioneers of optimized application hosting, featuring LiteSpeed Web Server & SSD Storage
Learn how we can make your website load faster, translating to better conversion rates for your business!

Reply With Quote
  #3  
Old 12-18-2005, 08:56 PM
funmaza funmaza is offline
Junior Guru Wannabe
 
Join Date: May 2005
Location: Pakistan
Posts: 73
thanx for your reply, but as i am new user i even do not know how to edit the httpd.conf

So, i would be greatfull if you do let me know.

Reply With Quote
Sponsored Links
  #4  
Old 12-18-2005, 09:11 PM
layer0 layer0 is offline
Performance Specialist
 
Join Date: Dec 2004
Location: New York, NY
Posts: 10,454
Simply use the shell command I gave you.

Quote:
replace "MaxClients 150" "MaxClients 300" -- /usr/local/apache/conf/httpd.conf;service httpd restart
that would be easier than manually editing it, but if you would like to manually edit it, try using:
Quote:
pico /usr/local/apache/conf/httpd.conf

__________________
MediaLayer, LLC - www.medialayer.com Lightning fast web hosting since 2005.
The pioneers of optimized application hosting, featuring LiteSpeed Web Server & SSD Storage
Learn how we can make your website load faster, translating to better conversion rates for your business!

Reply With Quote
  #5  
Old 12-18-2005, 09:22 PM
ScottJ ScottJ is offline
Web Hosting Master
 
Join Date: Feb 2005
Posts: 1,356
You may have to use nano instead of pico, because pico isnt an option on some OS anymore.

__________________
Eleven2 Web Hosting - World-Wide Hosting, Done Right!

Reply With Quote
  #6  
Old 12-18-2005, 09:28 PM
funmaza funmaza is offline
Junior Guru Wannabe
 
Join Date: May 2005
Location: Pakistan
Posts: 73
Hi,

Thanx alot i have edited httpd.conf and i hope it would'nt happen again..

A bundle of THANX

Reply With Quote
  #7  
Old 12-18-2005, 09:30 PM
layer0 layer0 is offline
Performance Specialist
 
Join Date: Dec 2004
Location: New York, NY
Posts: 10,454
Quote:
Originally Posted by SJRHosting.com
You may have to use nano instead of pico, because pico isnt an option on some OS anymore.
That is true but the same can be said about nano - many servers don't actually have nano installed.

__________________
MediaLayer, LLC - www.medialayer.com Lightning fast web hosting since 2005.
The pioneers of optimized application hosting, featuring LiteSpeed Web Server & SSD Storage
Learn how we can make your website load faster, translating to better conversion rates for your business!

Reply With Quote
  #8  
Old 12-18-2005, 11:41 PM
Dacsoft Dacsoft is offline
Web Hosting Master
 
Join Date: May 2003
Location: Florida
Posts: 877
Quote:
Originally Posted by funmaza
Hi,

Thanx alot i have edited httpd.conf and i hope it would'nt happen again..

A bundle of THANX
Remember that you must restart Apache for the changes to become effective. You can restart Apache using:
service httpd restart

Reply With Quote
  #9  
Old 12-25-2005, 05:53 PM
funmaza funmaza is offline
Junior Guru Wannabe
 
Join Date: May 2005
Location: Pakistan
Posts: 73
ok thanx for helping my problem has been solved

__________________
Best Entertainmnet Site,
Polyphonic Ringtones | Bollywood Stuff


Reply With Quote
  #10  
Old 12-25-2005, 08:58 PM
HD Fanatic HD Fanatic is offline
Web Hosting Master
 
Join Date: Jan 2005
Posts: 2,099
Seems that you don't have enough ram and apache isn't good for serving large files. Also, maybe you have some of script that restart apache when it reaches x load.

You could use lighttpd to serve those files, heard it's very good.

Reply With Quote
Reply

Related posts from TheWhir.com
Title Type Date Posted
Microsoft Gains Most Websites in May Netcraft Web Server Survey Web Hosting News 2014-05-09 11:38:05
Apache Market Share Falls in Netcraft October Web Server Survey Web Hosting News 2013-10-04 14:34:11
Apache Market Share Dips Slightly in June Netcraft Web Server Survey Web Hosting News 2013-06-06 13:40:21
Researchers Urge System Admins to Check for New Apache Web Server Backdoor Malware Web Hosting News 2013-05-01 11:35:53
CloudStack 4.0 Open Source Cloud Software Released as Apache Incubator Project Web Hosting News 2012-11-08 13:54:10


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes
Postbit Selector

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Forum Jump
Login:
Log in with your username and password
Username:
Password:



Forgot Password?
Advertisement:
Web Hosting News:



 

X

Welcome to WebHostingTalk.com

Create your username to jump into the discussion!

WebHostingTalk.com is the largest, most influentual web hosting community on the Internet. Join us by filling in the form below.


(4 digit year)

Already a member?