Results 1 to 7 of 7
  1. #1
    Join Date
    Jan 2005
    Posts
    231

    A very strange problem

    I have php 4.4.1 with gd enabled+all features.
    Everything working without problem but as soon as phpinfo() is disabled, scripts that require gd no longer working. I can't leave phpinfo() enabled because server is used for free hosting with automatic signups.
    Any idea?
    Thanks in advance!

  2. #2
    Join Date
    Nov 2005
    Location
    Czech Republic / Thailand
    Posts
    191
    What is ur OS?

    Cheers,
    Beruska
    Flash Live & VoD Streaming solutions 4 All.
    RTMP, HTML5, RTSP

  3. #3
    Join Date
    Jan 2005
    Posts
    231
    It's Fedora Core 3. For me it seems a php issue. With php 4.4 evrything was ok with phpinfo disabled.

  4. #4

    compile

    did you forget to compile in the support for gd?

  5. #5
    Join Date
    Jan 2005
    Posts
    231
    CartHost, I was very clear: gd is installed with all features. After my last tests, I discovered that problem appears with some scripts only.
    My conclusion: On php 4.4.0 was a bug fixed on 4.4.1. So, scripts that used this 'bug' no longer working on php 4.4.1 with phpinfo() disabled. I forgot to mention that safe_mode is On and also open_basedir.
    Maybe some old scripts need phpinfo to check if gd is enabled...
    That's why I think it's strange.

  6. #6

    try

    try setting those options in the .htaccess
    and see if the scripts are working?

  7. #7
    Join Date
    Jan 2005
    Posts
    231
    safe_mode on/off or open_basedir restriction disabled, everything the same.
    with phpinfo enabled working, with phpinfo disabled the same script not working.
    With php 4.4 I don't have this issue.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •