Results 1 to 10 of 10
  1. #1

    Arrow lost in DNS world

    Just got a new dedicated server running:

    redhat linux 3
    cpanel 10

    I am having a problem with my DNS, not sure if everything is setup correctly. When I run DNS report, I get a lame server error. I have tried a lot of what is suggested in this forum but to no success. What am I missing? Tell me what I need to share to receive some help. the domain name is enigmainnovations(dot)com.

    Thanks.

  2. #2
    Join Date
    Jul 2002
    Location
    Malaysia
    Posts
    698
    check your domain DNS zone in /var/named and make sure it is correct, you may try the following command as well:

    /scripts/fixndc ( run twice )
    service named restart ( run twice )

  3. #3
    Still no luck. How many DNS zone files should I have? Right now, I only see one for my main account.

  4. #4
    Should each nameserver that I want to host have a zone record?

  5. #5
    Join Date
    Mar 2005
    Location
    Sri Lanka\Colombo
    Posts
    357
    ok first, did you creat a domain call enigmainnovations-com ? coz i dont see you have. your name server are working fine, and i see that you have registerd them.

    creat a accout with WHM for enigmainnovations-com

    it should fix the prb.

    also add A in the DNS zone (WHM ---> Edit a DNS Zone --> enigmainnovations-com)

    dns1 IN A 70.86.190.2
    dns2 IN A 70.86.190.3

    hope this helps

  6. #6
    Dnsreport says the serial numbers are different !

    It seems that your primary and secondary name servers are not synced.
    I think you are maintaining DNS zones separately in both the servers.

    You should have one server as primary server and edit zone file in the primary server only. And your secondary (or slave) nameserver should be configured such that it gets zone records from the primary server.

    Make sure when you update the serial numer in primary server and reload the zone, it is automatically updated in the seconday server.




    Also make sure your SOA record is correct.



    Best regards,
    Unixsolutions
    info at unixsolutions.us

  7. #7
    Made some progress. Could someone tell me what is still missing? When I run dnsreport most of the fails and warnings are gone, but I still have one that is bothering me and I am not sure what to do. The error message is as follows:

    WARNING: Your nameservers do not include any corresponding A records when asked for your NS records. They probably are not returning the A records when asked, which can prevent some other DNS servers from contacting your DNS servers. They should do this if they are authoritative for those A records. The problem record(s) are: Nameserver XX.XX.XXX.2 did not provide IPs for all NS records (but did provide at least one)
    Nameserver XX.XX.XXX.3 did not provide IPs for all NS records (but did provide at least one)
    Any ideas?

  8. #8
    Join Date
    Mar 2005
    Location
    Sri Lanka\Colombo
    Posts
    357
    "also add A in the DNS zone (WHM ---> Edit a DNS Zone --> enigmainnovations-com)

    dns1 IN A 70.86.190.2
    dns2 IN A 70.86.190.3"

  9. #9
    if the nameservers entered at the registrar does not match with the entry in teh zone file of the domain in the server, stealth error is hown in dnsreport

  10. #10
    There is an A record in the zone file for dns1 and dns2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •