Results 1 to 3 of 3
  1. #1
    Join Date
    Nov 2005
    Location
    Denver, CO
    Posts
    728

    CPanel - Apache, PHP, PERL versions

    I've been a long time Plesk user, very happy with it but I've recently decided to switch hosts for a variety of reasons. They don't offer Plesk but CPanel. Now I haven't used CPanel in 2+ years but last time I used it I absolutely hated it and found it to be irritatingly unstable. But things change however...

    I've played around with multiple CPanel demos and it appears that every CPanel server is running Apache 1.x instead of 2.0.5x. Is that the case? CPanel is only compatible w/ Apache 1.x? What about PHP? I want to run 4.3.11 at an absolute minimum for security reasons but if I recall correctly, it doesn't run correctly w/ Apache 1.x. What about PERL? Or is that just what the hosting company installs and I can freely upgrade to later versions of PHP and httpd?

    That was my one beef w/ Plesk was that it used older versions of hhtp and php, usually a patch or two behind in support. Anyways, thanks in advance for any answers.

  2. #2
    Join Date
    Nov 2002
    Location
    Under the sea
    Posts
    4,208
    Quote Originally Posted by CiscoMike
    I've been a long time Plesk user, very happy with it but I've recently decided to switch hosts for a variety of reasons. They don't offer Plesk but CPanel. Now I haven't used CPanel in 2+ years but last time I used it I absolutely hated it and found it to be irritatingly unstable. But things change however...

    I've played around with multiple CPanel demos and it appears that every CPanel server is running Apache 1.x instead of 2.0.5x. Is that the case? CPanel is only compatible w/ Apache 1.x? What about PHP? I want to run 4.3.11 at an absolute minimum for security reasons but if I recall correctly, it doesn't run correctly w/ Apache 1.x. What about PERL? Or is that just what the hosting company installs and I can freely upgrade to later versions of PHP and httpd?

    That was my one beef w/ Plesk was that it used older versions of hhtp and php, usually a patch or two behind in support. Anyways, thanks in advance for any answers.
    4.3.11 runs perfectly fine with Apache 1.x

  3. #3
    Join Date
    Nov 2005
    Location
    Denver, CO
    Posts
    728
    hmmm, I could have sworn I had seen/heard otherwise but that's fine. Regardless, I'd rather *not* run older versions of Apache if at all possible (or PHP, PERL, GD, ImageMagick, OpenSSL, etc). Not looking for latest and greatest but something a bit more current.

    anyways, any comments on CPanel and compatibility with httpd 2.0.5x?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •