Results 1 to 5 of 5
  1. #1
    Join Date
    May 2003
    Location
    Florida
    Posts
    192

    Any known cpanel/whm issues with PHP 5.x

    I have been considering upgrading to PHP5 but am concerned about any known issues with major scripts breaking like Neomail, Horde etc.

    Anyone on PHP5.x?
    Kimrari

  2. #2
    Join Date
    Feb 2003
    Location
    North Hollywood, CA
    Posts
    2,554
    on the cPanel forums, they say or helpers say you should add the extension as in .php5

    I haven't tried fully upgrading to php5 but i installed it so some clients can use it.
    Remote Hands and Your Local Tech for the Los Angeles area.

    (310) 573-8050 - LinkedIn

  3. #3
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,290
    cpanel uses an internal version of php for the horde/neomail/etc.. You will be fine.
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  4. #4
    Join Date
    Nov 2003
    Location
    Oklahoma
    Posts
    146

    Re: Any known cpanel/whm issues with PHP 5.x

    Originally posted by kimrari
    I have been considering upgrading to PHP5 but am concerned about any known issues with major scripts breaking like Neomail, Horde etc.

    Anyone on PHP5.x?
    We are running php5 with Cpanel and no problems with the mail programs. However neomail is gone if you update because of the new security risks. I had to fix some OSCommerce sites and Cerberus Support center because of PHP 5
    Regards,
    Randy
    Okie Net Web Hosting

  5. #5
    Join Date
    Sep 2005
    Location
    In canada
    Posts
    3,213
    You should be prepared to hear lots of problems from ur customers that have forums running as most forums are not compatible with php5 we had to downgrade to php4 just for the same reason. So , there is basically not an issue with php5 and cpanel and whm but its an issue with the forums cause most are note compatible yet.
    So , its your choice to decide.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •