Results 1 to 6 of 6
  1. #1

    problem with running UML!

    Hi
    I've just used the "HOW TO VDS" tutorial to use UML, but I fail
    http://www.webhostingtalk.com/showth...hreadid=291979

    when I run the following command, after a bit, a welcome text will appear and after that, my ssh hangs and I just have to start a new ssh session!
    The Command: "/home/vds1/linux ubd0=root_fs root=/dev/ubd0 mem=128m"

    may someone helping me to solve the problem?

    Thanks

  2. #2
    post exact what goes out as fault

    check if the paths is ok
    and the root=/dev/ubd0 not need it .
    EdgeVPS
    http://www.edgevps.com

  3. #3
    well, it's exactly what happen when I run the linux:


    [[email protected] vds4]# /home/vds4/linux ubd0=root_fs root=/dev/ubd0 mem=128m
    Checking for the skas3 patch in the host...not found
    Checking for /proc/mm...not found
    tracing thread pid = 4192
    Linux version 2.4.22-8um ([email protected]) (gcc version 3.3 (Debian)) #2 Fri Aug 29 21:13:01 EDT 2003
    On node 0 totalpages: 32768
    zone(0): 32768 pages.
    zone(1): 0 pages.
    zone(2): 0 pages.
    Kernel command line: ubd0=root_fs root=/dev/ubd0 mem=128m
    Calibrating delay loop... 3776.97 BogoMIPS
    Memory: 125076k available
    Dentry cache hash table entries: 16384 (order: 5, 131072 bytes)
    Inode cache hash table entries: 8192 (order: 4, 65536 bytes)
    Mount cache hash table entries: 512 (order: 0, 4096 bytes)
    Buffer cache hash table entries: 4096 (order: 2, 16384 bytes)
    Page-cache hash table entries: 32768 (order: 5, 131072 bytes)
    Checking for host processor cmov support...Yes
    Checking for host processor xmm support...No
    Checking that ptrace can change system call numbers...OK
    Checking that host ptys support output SIGIO...Yes
    Checking that host ptys support SIGIO on close...No, enabling workaround
    POSIX conformance testing by UNIFIX
    Linux NET4.0 for Linux 2.4
    Based upon Swansea University Computer Society NET3.039
    Initializing RT netlink socket
    Starting kswapd
    VFS: Disk quotas vdquot_6.5.1
    devfs: v1.12c (20020818) Richard Gooch ([email protected])
    devfs: boot_options: 0x1
    JFFS version 1.0, (C) 1999, 2000 Axis Communications AB
    JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.
    pty: 256 Unix98 ptys configured
    SLIP: version 0.8.4-NET3.019-NEWTTY (dynamic channels, max=256).
    RAMDISK driver initialized: 16 RAM disks of 4096K size 1024 blocksize
    loop: loaded (max 8 devices)
    PPP generic driver version 2.4.2
    Universal TUN/TAP device driver 1.5 (C)1999-2002 Maxim Krasnyansky
    SCSI subsystem driver Revision: 1.00
    scsi0 : scsi_debug, Version: 0.61 (20020815), num_devs=1, dev_size_mb=8, opts=0x0
    Vendor: Linux Model: scsi_debug Rev: 0004
    Type: Direct-Access ANSI SCSI revision: 03
    blkmtd: error: missing `device' name

    Initializing software serial port version 1
    mconsole (version 2) initialized on /root/.uml/1ZbMCb/mconsole
    Partition check:
    ubda: unknown partition table
    UML Audio Relay (host dsp = /dev/sound/dsp, host mixer = /dev/sound/mixer)
    Initializing stdio console driver
    NET4: Linux TCP/IP 1.0 for NET4.0
    IP Protocols: ICMP, UDP, TCP
    IP: routing cache hash table of 512 buckets, 4Kbytes
    TCP: Hash tables configured (established 8192 bind 16384)
    NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
    VFS: Mounted root (ext2 filesystem) readonly.
    Mounted devfs on /dev
    INIT: version 2.78 booting
    Welcome to Red Hat Linux
    Press 'I' to enter interactive startup.
    Mounting proc filesystem: Child 4256 exited with signal 11
    and after it, I just can't enter anymore command and can't do anything with SSH. I have to close it and connect to ssh again!

  4. #4
    post the /etc/fstab
    and the /etc/mtab
    EdgeVPS
    http://www.edgevps.com

  5. #5
    Join Date
    Jun 2003
    Location
    UK
    Posts
    6,601
    Loop mount the file system and chroot into it then run

    mv /usr/lib/tls /usr/lib/tls.broken
    mv /lib/tls /lib/tls.broken

    Umount the image and reboot it

    Rus
    Russ Foster - Industry Curmudgeon

  6. #6
    And the kernel you are running is 2 years old. It'd pay to build a newer one. e.g. the latest blaisorblade bs version.
    RimuHosting.com - VPS Hosting and Dedicated Server Hosting since 2003
    Pingability.com - Peace of Mind Web Site Monitoring

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •