Results 1 to 12 of 12
  1. #1

    help for making CLEAN URLS (.htaccess)

    Hey all..

    Usually I try my best to figure out things, but I failed this time.
    I have tried everything, but I can get the CLEAN URLS work, I have read several tutorials and they are same for example

    I have tried this one, and others but I get "Internal Server Error"..
    here is the copy of error I get

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.
    Please contact the server administrator, [email protected] and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.


    Apache/1.3.33 Server at Port 80

    I dont know whats wrong and where is the problem, here is the test url..

    I would really appreciate if anyone can help here, I can give him/her access to my server to figure out the problem.


  2. #2
    Join Date
    Jun 2003
    Proud She-Geek
    If you're getting an ISE with mod_rewrite, it means it's not enabled on your server.

    Either you or your host will need to enable it in php.ini.
    <?php echo "Signature here"; ?>

  3. #3
    Join Date
    Jan 2005
    Or apache isn't understanding the input from .htaccess, or malformed/missing URL/page

  4. #4
    thanks both for your replies.

    the following code is in my .htaccess file

    <Files article>
    ForceType application/x-httpd-php
    and the code is my php

    <? echo"testing urls"; ?>

    I also tried using this
    $var_array = explode("/",$PATH_INFO);
    $a=$var_array[1] ;

    it works without using .htaccess and removing the file extensions.

    should I ask my host to enable remod_write ?
    any ideas ?

  5. #5
    ok - I did another test, I placed the following code in .htaccess to display custom error pages.

    ErrorDocument 404 /notfound.html

    but its nor displaying this url, I have placed this notfound.html in root folder here

    Does it mean the .htaccess is not allowed on my server or something ?

  6. #6
    Join Date
    Jan 2005
    mod_rewrite is pretty standard and should be enabled by your host, the only issue that they could complain about is the extra CPU usage, which is minimal unless your rewrites are huge.

    To see if it is enabled, create a file named phptest.php and add the following to it:

    <?php phpinfo(); ?>

    Then navigate to that page and check which modules are loaded for apache. Delete the file when you're done.

  7. #7
    nah thats does not work actually, it seems that .htaccess is not working. I have placed the following code in .htaccess file

    ErrorDocument 404 /notfound.html

    and placed notfound.html files in root directory, it must display custom error page on page not found 404, but it does not. I tihnk ,htaccess is not configured properly, may be.

  8. #8
    I've been trying to do this as well, because I want

  9. #9
    Bumping this once.

  10. #10
    I find this website useful for mod_rewrite

  11. #11
    Join Date
    Aug 2005
    I used a similar site for my Clean URL needs and it wasnt too helpful as the URLs didnt work once I applied the PHP...

    Thanks for the URL, very useful.

  12. #12
    Thatnks for the link, but I have a question though: what if you're not using an e-store? I find that all these articles keep using e-store examples & I don't need mod_rewrite for one.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts