Results 1 to 10 of 10

Thread: libdb-3.2.so

  1. #1
    Join Date
    Apr 2005
    Location
    United Kingdom
    Posts
    60

    libdb-3.2.so

    Hey,

    I am loading Directadmin onto RedHat 7.3 but can't find the following RPM / Package as exim needs it.

    libdb-3.2.so

    Anyone know where to locate this file?

    Chris

  2. #2
    Join Date
    Dec 2002
    Location
    California
    Posts
    2,005
    Dare we even ask why you're using RH 7.3?
    I wish all my traffic went through AS174.

  3. #3
    Join Date
    Apr 2005
    Location
    United Kingdom
    Posts
    60
    Im just testing it generally on a vz node, its a sw-soft compiled build.

    Chris

  4. #4
    Join Date
    Jun 2003
    Posts
    961
    no luck with db3-3.3.11-6.i386.rpm or db3x-3.2.9-4.i386.rpm ?

  5. #5
    Join Date
    Apr 2005
    Location
    United Kingdom
    Posts
    60
    Nope,

    Just tried those rpm's with no change.

    [[email protected] /]# service exim restart
    Shutting down exim:
    Starting exim: /usr/sbin/exim: error while loading shared libraries: libdb-3.2.so: cannot open shared object file: No such file or directory

    Is the error im getting.

    Chris

  6. #6
    Join Date
    Jun 2003
    Posts
    961
    i just tested and /lib/libdb-3.2.so is included in db3x-3.2.9-4.i386.rpm
    did you try "ldconfig" ?
    what does "ldd /usr/sbin/exim" return?

  7. #7
    Join Date
    Apr 2005
    Location
    United Kingdom
    Posts
    60
    It returns the following;

    [[email protected] root]# ldd /usr/sbin/exim
    libresolv.so.2 => /lib/libresolv.so.2 (0x40019000)
    libnsl.so.1 => /lib/libnsl.so.1 (0x4002a000)
    libcrypt.so.1 => /lib/libcrypt.so.1 (0x4003e000)
    libdb-3.2.so => not found
    libdl.so.2 => /lib/libdl.so.2 (0x4006b000)
    libm.so.6 => /lib/libm.so.6 (0x4006e000)
    libc.so.6 => /lib/libc.so.6 (0x4008f000)
    libssl.so.2 => /lib/libssl.so.2 (0x401b7000)
    libcrypto.so.2 => /lib/libcrypto.so.2 (0x401e4000)
    /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)


    Chris

  8. #8
    Join Date
    Apr 2005
    Location
    United Kingdom
    Posts
    60
    I just done the following and it seems to of fixed it

    [[email protected] lib]# cp libdb-3.3.so libdb-3.2.so
    [[email protected] lib]# service exim restart
    Shutting down exim:
    Starting exim:
    [[email protected] lib]#

    Chris

  9. #9
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,294
    Chris, if it doesnt work, just grab the src rpm from the directadmin files, and build it for your os.
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  10. #10
    Join Date
    Apr 2005
    Location
    United Kingdom
    Posts
    60
    Yeah its working fine now,

    Thanks thelinuxguy, i'll jot that down incase it all goes pear shaped over the next few hours.

    Chris

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •