Results 1 to 4 of 4
  1. #1
    Join Date
    May 2005
    Location
    Balmumcu, Istanbul, TR
    Posts
    20

    PHP file requested but the page did not come...

    I have requested a PHP file, I see the following in the access logs:
    85.100.59.59 - - [31/Jul/2005:18:47:51 +0300] "GET /ticket/admin.php HTTP/1.1" 200 - "-" "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6"
    but the requested page did not come to my browser. What may cause this? Any ideas?

  2. #2
    Join Date
    Jul 2005
    Posts
    79
    Blank page may appear in result of an error in php code, when displaying errors directly on page is turned off (what is correct behaviour in production environment). If there is no output about any php errors in apache's error_log - the logging may be turned off completely.

    You can setup error displaying and logging in php.ini or directly in php script - details available here:

    http://www.php.net/errorfunc

  3. #3
    Join Date
    May 2005
    Location
    Balmumcu, Istanbul, TR
    Posts
    20
    Strangely, blank page does not appear. First I request the page, login box comes up, I fill it in and submit it, my firefox turns turns and turns and suddenly it stops. No page changing. Still the same screen with the filled form is seen on the browser...

  4. #4
    Join Date
    Jul 2005
    Posts
    79
    There can be numerous reasons for that... not much can be said without insight into webserver's logs and/or script's sourcecode.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •