Results 1 to 4 of 4
  1. #1
    Join Date
    Mar 2005
    Location
    UK
    Posts
    28

    mysql does not support authentication protocol requested by server

    hey i keep getting this error after connecting and selecting a database.
    im useing Apache HTTP Server 2.0.54 andphp-4.4.0.

    Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in C:\Program Files\Apache Group\Apache2\htdocs\index.php on line 7




    <html>
    <title> WOW NOW </title>
    <body>

    <?php

    $conn = mysql_connect('localhost','root','password');

    ?>


    </body>
    </html>

  2. #2
    Look here: dev.mysql.com/doc/mysql/en/old-client.html

    I was unable to put an actual link here, because vBulletin has a rule that I should make 5 posts first. Duh

    Cheers.

  3. #3
    Join Date
    May 2003
    Posts
    1,664
    In your my.cnf put in old-password for one of the options. You have 4.1.x of MySQL and your application is looking for 4.0.x style passwords.

  4. #4
    Join Date
    Mar 2005
    Location
    UK
    Posts
    28
    what if i put SQL 4.0 on my PC ?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •