Results 1 to 3 of 3
  1. #1
    Join Date
    Mar 2005

    help with daily-occurring iowait issues... the linux guy?

    It seems every night around 9:30pm, my server is getting practically taken down by some background process that is maxing out the IOWAIT on my processors, rendering the server nearly inaccessible. I've disabled all of the CPanel daily updates, and removed their cron jobs, but it seems to still run every night, even though my update settings are all disabled.

    I've heard something about 'auditd' causing this problem. What is that and should I disable it (and if so, how)?

    Also, is there any way to improve the iowait situation by updating the kernel, or is there anything else i can do? after searching on here, it seems 'the linux guy' is a guru for this kind of thing.

    Any help would be appreciated.


    CentOS 3.5
    kernel - 2.4.21-32.0.1.ELsmp
    cpanel/apache 1.3.33/php 4.3/mysql 4.01

  2. #2
    Join Date
    Jun 2005
    If its auditd (you should be able to tell):

  3. #3
    Join Date
    Sep 2004
    Dallas, TX
    'man auditd'

    auditd - collect system call audit records and write them to file

    auditd [OPTION]...

    Auditd collects audit records generated by the kernel system call audit mechanism, and writes them to disk.

    Try using tools like top to try and figure out what process is consuming all the IO bandwidth every night. If the problem happens at the same time every night, check /etc/crontab and 'crontab -e' as root to see what scripts execute at that time. High IOwait times is related to not enough IO bandwidth, usually disk related. You're running the latest kernel for your distribution, so that shouldn't be an issue.
    Last edited by Inthrive; 07-31-2005 at 04:00 AM.
    I N T H R I V E
    when you can't afford downtime
    [email protected]
    High Availability Web Hosting

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts