Forgive me if this made it to WHT before this post...

Although I have yet to see a public proof of concept or tested exploit, it would be wise to upgrade per the advisory's instructions:

MySQL Update Link:

Security improvement: Applied a patch that addresses a zlib data vulnerability that could result in a buffer overflow and code execution. (CAN-2005-2096) (Bug #11844)