Results 1 to 5 of 5
  1. #1
    Join Date
    May 2003
    Location
    California, USA, Earth
    Posts
    1,049

    mod rewrite help!

    This is what I have in my .htaccess file:

    Options +FollowSymlinks
    RewriteEngine on
    RewriteBase /
    RewriteRule ^([0-9A-Z]+) rsvp.php?i=$1 [R=301,L]

    What it does is this:

    Visit www.domain.com/6V2CV05MOCWU56SVWVNEODUA6

    it passes that string to rsvp.php?i=6V2CV05MOCWU56SVWVNEODUA6 and shows it as this in the browser:

    http://www.domain.com/rsvp.php?i=6V2...U56SVWVNEODUA6

    I'd like it to show up as www.domain.com/6V2CV05MOCWU56SVWVNEODUA6 how can I do this?

    Your help is MUCH appreciated!! I've been trying to figure this one out for a few days.
    Blesta - Professional Billing Software
    Innovation that benefits the user experience
    Trial - Demo | 866.478.7567 | Twitter @blesta

  2. #2
    Join Date
    May 2004
    Location
    Lansing, MI, USA
    Posts
    1,548
    end it with [L] and not [R=301,L]

    Your done

    Nice to see you on WHT and not via phone/email
    Jacob - WebOnce Technologies - 30 Day 100% Satisfaction Guarantee - Over 5 Years Going Strong!
    Website Hosting, PHP4&5, RoR, MySQL 5.0, Reseller Hosting, Development, and Designs
    Powered By JAM - Professional Website Development - PHP, MySQL, JavaScript, AJAX - Projects Small & Large

  3. #3
    Join Date
    Jul 2005
    Posts
    256
    Ending it with [L,NS] would do even better. No error 500's.

  4. #4
    Join Date
    May 2003
    Location
    California, USA, Earth
    Posts
    1,049
    That works great! Thanks guys.. part of the problem was with testing different things, Firefox would cache things and screw me up.

    Nice to see you on WHT and not via phone/email
    haha. thanks WebOnce, same. took me a minute to figure out where i knew you from. hope all is well!
    Blesta - Professional Billing Software
    Innovation that benefits the user experience
    Trial - Demo | 866.478.7567 | Twitter @blesta

  5. #5
    Join Date
    May 2004
    Location
    Lansing, MI, USA
    Posts
    1,548
    Originally posted by wshost
    That works great! Thanks guys.. part of the problem was with testing different things, Firefox would cache things and screw me up.



    haha. thanks WebOnce, same. took me a minute to figure out where i knew you from. hope all is well!
    Yeah... firefox caches 301's which is a pain...

    Yeah, all is going well HOPEFULLY we will stop bumping into each other outside of WHT, clients permitting... pesky clients... always causing trouble...
    Jacob - WebOnce Technologies - 30 Day 100% Satisfaction Guarantee - Over 5 Years Going Strong!
    Website Hosting, PHP4&5, RoR, MySQL 5.0, Reseller Hosting, Development, and Designs
    Powered By JAM - Professional Website Development - PHP, MySQL, JavaScript, AJAX - Projects Small & Large

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •