Results 1 to 5 of 5
  1. #1

    Dedicated Server DNS Issue

    I just purchased one of the servers that the planet offers. I went in to "edit setup" and then proceeded to assign nameservers to the server.

    It would not accept them. It tells me "Sorry, the nameserver ns1.mydomain.com already has the ip xx.xxx.xx.xx assigned to it.

    I ran a search here for the issue and found where someone said to just change it to dns1.mydomain.com and then change it back once I made the change and my registrar.

    It would accept dn1.mydomain.com as the primary but when I tried to assign dns2.mydomain.com as the secondary it tells me
    "Sorry, you are out of ips to assign as nameservers "

    Questions are:

    1) Why would it not allow the primary to be set as ns1.mydomain.com to start with? I have IP Sharing on!

    2) How can I get it to accept ns1.mydomain.com?

    3). Why is it tell me "Sorry, you are out of ips to assign as namservers" when I know that I have 10 ip address?

    any thoughts or ideas? I have searched the forums here and someone suggested that I ssh into the server which I did.

    All you need to do is edit /etc/nameserverips and put your Nameservers to the IPs you've assigned them. If the file is blank then run:

    WHM > Server Setup > Manage Nameserver IPs

    and then edit the file.
    I login as root and get "permission denied" when I try to edit the file.

    Any help is greatly appreciated.

  2. #2
    Join Date
    Jun 2003
    Location
    UK
    Posts
    6,601
    Try

    chattr -i /etc/nameserverips from the SSH prompt

    Or you can contact contact the tech support dept of your provider

    Rus
    Russ Foster - Industry Curmudgeon

  3. #3
    Thank you. Will try both.

  4. #4
    Join Date
    May 2002
    Location
    Moscow
    Posts
    1,490
    you may also select option in Edit Setup -> Tweak Settings -> Disable whois lookups for the nameserver ip manager menu.
    Rustelekom LLC Dedicated server since 2002, RIPE NCC member, LIR, AS51168

  5. #5
    Worldhosting, I disabled and now it tells me

    "Sorry, you are out of ips to assign as nameservers"

    How can I free up the ips to assign please?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •