Results 1 to 16 of 16
  1. #1
    Join Date
    Aug 2004
    Posts
    54

    seperating webserver and mysql server ?

    Hi !

    we are building a php web application for a heavy traffic site. We have planned to use 3 servers, 1 webserver, 1 mysql server and 1 mail server.

    now when we run our php application on a server having both mysql and apache, the page opens in 0.12 sec.

    but when we seperate our php application and mysql server, it takes 5.12 sec to process the page .

    why ? it should give us good performance rather then decreasing the performance. both computers are connected with each through LAN and we are using internal ip address ie 192.168.0.4 to connect to mysql and the servers are hosted on liquidweb.


    any suggestions on improving the performance ?

    regards,

  2. #2
    Join Date
    Jul 2003
    Location
    Earth
    Posts
    1,692
    Are your servers managed?

    Have you asked LiquidWeb about this issue?

  3. #3
    Join Date
    Dec 2004
    Location
    New York City, NY, USA
    Posts
    735
    Is your PHP application using persistent connections (mysql_pconnect)?

    Without pconnect there is a *large* overhead in creating a TCP/IP connection to a remote server.

  4. #4
    Join Date
    Aug 2004
    Posts
    54
    yes, all my servers are managed.

    1st of all, i want to make sure, is this an issue ? did connecting remote mysql server on a lan produce this much delay ?

    the lan is normal ethernet card with 10/100 and normal cables.

    yes, i send them email, but they are very slow in support.

  5. #5
    Join Date
    Aug 2004
    Posts
    54
    i tried to create pconnect and the result was more worst then with connect. before it was taking 5.12 sec and after using pconnect it took 10.12 secs to connect.

  6. #6
    Join Date
    Dec 2004
    Location
    New York City, NY, USA
    Posts
    735
    What is the ping between the web and MySQL servers?

  7. #7
    Join Date
    Aug 2004
    Posts
    54
    here is the ping result.

    PING 192.168.0.4 (192.168.0.4) 56(84) bytes of data.
    64 bytes from 192.168.0.4: icmp_seq=0 ttl=64 time=0.076 ms
    64 bytes from 192.168.0.4: icmp_seq=1 ttl=64 time=0.076 ms
    64 bytes from 192.168.0.4: icmp_seq=2 ttl=64 time=0.067 ms

    --- 192.168.0.4 ping statistics ---
    3 packets transmitted, 3 received, 0% packet loss, time 2018ms
    rtt min/avg/max/mdev = 0.067/0.073/0.076/0.004 ms, pipe 2

  8. #8
    Join Date
    Dec 2004
    Location
    New York City, NY, USA
    Posts
    735
    I'm not sure what to say. Those were all the obvious things to check... Since you've a managed setup you definitely want Liquidweb to look into it.

    Putting a MySQL server on a separate machine does NOT create that much delay. I've a cluster setup I use at home for development--and I never even measured if it was any slower/faster, because I noticed no difference.

  9. #9
    Join Date
    Jul 2003
    Location
    Earth
    Posts
    1,692
    Originally posted by jmansoor
    yes, i send them email, but they are very slow in support.
    Really? I would have thought just the opposite...

  10. #10
    Join Date
    Aug 2004
    Posts
    54
    i have been with dedicated now and now with them. i choose them because of 100%.

    there response some time is fast and some time very slow. im comparing it with DN, i can say DN is far ahead in support then liquid web.

    this is my practicle experience. i have rite now, three tickets open with them. and i am receiving response in about 24 hrs, which is pathatic as compare to DN.

  11. #11
    Join Date
    Mar 2004
    Location
    New York City
    Posts
    995
    If you're moving to three servers, it maybe a good time to look at investing in a managed or unmanaged cluster.

    Regards,
    Sam
    Sam Machiz / Director, Product Development / Ubersmith
    smachiz[at]ubersmith.com / [direct] 212-812-4194

  12. #12
    Join Date
    Aug 2004
    Posts
    54
    I just checked the php application again and now it's working perfectly with local lan. the pages are processing in 0.12 sec. i don't know what has changed. may be Liquid web did some changes in the configuration, but i did'nt receieve any response from them regarding any changes.

    Thanks every body for their help.

  13. #13
    Join Date
    Jul 2003
    Location
    Earth
    Posts
    1,692
    Great you got your issue solved. Let us know whether this was solved by LiquidWeb staff or not...

  14. #14
    Join Date
    Aug 2004
    Posts
    54
    sure, i'm waiting for any response from their side.

  15. #15
    Join Date
    Sep 2004
    Location
    Flint, Michigan
    Posts
    5,765
    From what I have read LiquidWeb's ticket support is lacking, but their phone support is right one. I'd give them a ring.
    Mike from Zoodia.com
    Professional web design and development services.
    In need of a fresh hosting design? See what premade designs we have in stock!
    Web design tips, tricks, and more at MichaelPruitt.com

  16. #16
    I have the exact same problem. But I have a very busy site. 1.5million hits per day. Alexa rank between 1000 ~ 2000. All performance decrease and even has server crash all the times when I seperate the Web and MySQL.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •