Results 1 to 3 of 3

Thread: imap issues

  1. #1

    imap issues

    Okay I'll try to explain this in full, please read entire post.

    Do not ask me to contact technical support, since I'm on a unmanaged server where technical support costs 70$ USD..


    Okay:
    I'm using cPanel on Cent OS 4

    Trouble #1
    Imap wont start
    when restarting it says:
    "inetd has failed, please contact the sysadmin. "

    Trouble #2
    Horde and Squirrelmail does not work. Horde says:
    "Notice: (null)(): Connection failed to localhost,143: Connection refused (errflg=2) in Unknown on line 0"

    Soo.. I thought this might be a port problem (143) in my firewall (APF) , i checket the TCP ports and 143 was listed correctly.

    I then uninstalled APF, flushed iptables, reinstalled iptables, and of course restarted the server and everything again.

    But still nothing..

    Does anyone have a clue what this is?
    I have tried /scripts/fixeverything without any luck

    I have a feeling this can have something to do with /etc/resolv.conf but as far as I can see the nameservers are setup correctly.

    My resolv.conf says:
    nameserver mydnsip1
    nameserver mydnsip2

    (mydnsip1 and 2 is of course the correct ip adresses for my nameservers) It it something else in resolv.conf I should be aware of?

    ------------

    I need to fix this fast, the problem is that I have alot of programs/ scripts running that cannot send emails, and I'm rather frustrated.

    Please help!

  2. #2
    Okay. I'm one step closer:

    cp -f /usr/local/cpanel/3rdparty/bin/imapd /usr/sbin/imapd
    /etc/rc.d/init.d/xinetd restart

    restarted the inetd okay, but Imap still does not work, i tried changing the

    I tried the following:
    Try to
    pico /etc/xinetd.d/imap
    Change the line server = imapd into
    server = /usr/sbin/imapd

    that did not work either

    This however got my Squirrelmail working, but Horde still have a problem.

  3. #3
    Problem solved!

    Okay here is what I did. .. ( read the above post )

    After doing that I rebuild Apache with imap, stopped xinetd and restarted it.

    then I had to wait a few minutes. Now Imap is up and running! Hooray!

    I hope this little internal talking to myself can help someone else out later on

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •