Results 1 to 8 of 8

Thread: Ready to pay

  1. #1
    Join Date
    Mar 2002

    Ready to pay

    Okay, I'm extremely frustrated and I am ready to pay for someone to figure out what the hell my servers problem is because I need this fixed ASAP!!!!

    I have a PHP script that uploads files. Whenever uploading files larger than 16M I get a message about "Got packet larger then 'max_allowed_packet'". Now, at first I was having a problem with getting my setting for max_allowed_packet to show up, then i read that mysql 3.2 only allows up to 16M for that value.

    I read around and found that Plesk 7.5 supports MySQL 4. So I found instructions on how to upgrade to mysql 4 and did so via and the plesk forums. I added the ART channels to my config and used "up2date mysql" to update mysql. Now i've checked and sure enough it's updated to mysql4 so it now shows that max_allowed_packet is set to 1GB. Still doesnt work with files larger than 16M! So I've changed every relative value in the php.ini file as well as putting a .htaccess file with LimitRequestBody set really high.

    Still doesn't work! I've looked all around and the only thing I can find that might explain what is going on is the fact that my php is still linking to the mysql3 library. According to what I have read, there is a problem with sending packets over 16M between PHP and the MySQL 3x library. It is suggested that I rebuild PHP with the library for my mysql4 installation.

    I've looked all around and cannot find good, detailed instructions on how to do this and I am afraid that if I do this I am going to break something w/ Plesk or something else on the server. I also don't want to do this and it not fix the problem.

    Here is my relative php.ini settings and my.cnf




    PHP.ini relative settings (ive set everything really high just for now, once i get it working i'll tune the settings)
    ; Resource Limits ;

    max_execution_time = 3000
    max_input_time = 6000
    memory_limit = 302M
    post_max_size = 300M
    upload_max_filesize = 300M

    It couldn't have to do with "default_socket_timeout = 60" could it?

    I also have a .htaccess file in the directory with LimitRequestBody set to 0 (which is supposed to be unlimited).

    MySQL: 4.0.24
    PHP: 4.3.11
    MySQL Client API: 3.23.58

  2. #2
    Join Date
    Mar 2002
    I find it hard to believe out of everyone, no one knows what is going on!

  3. #3
    this may be a stupid reply, but did you consider the php script could be limiting the max file size?

  4. #4
    Join Date
    Mar 2002
    I wrote the script so I know it's not

    Basically all it is, a basic file upload script. It takes the file and plops it into a mysql database.

    Also - if it was a php script issue, i wouldnt get the MySQL error.

  5. #5
    good point...
    anyway, hope you find the problem

  6. #6
    Bad Luck
    hope you find someone help you

  7. #7
    Join Date
    May 2004
    Lansing, MI, USA
    I believe you just need a recompile of PHP. If you wish, contact me and we can figure it out for you
    Jacob - WebOnce Technologies - 30 Day 100% Satisfaction Guarantee - Over 5 Years Going Strong!
    Website Hosting, PHP4&5, RoR, MySQL 5.0, Reseller Hosting, Development, and Designs
    Powered By JAM - Professional Website Development - PHP, MySQL, JavaScript, AJAX - Projects Small & Large

  8. #8
    Join Date
    Jan 2005
    Chisinau, Moldova
    I guarantee that I'll fix this problem.
    mail me.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts