Results 1 to 4 of 4
  1. #1
    Join Date
    Jan 2005
    Posts
    268

    Question is there something wrong with eaccelerator-0.9.3 ?

    Hi everyone

    I installed eaccelerate follow this instruction http://forum.ev1servers.net/showthre...&page=1&pp=25. For the first few days, it was running ok. But today when i restart apache"


    Code:
    [email protected] [~]# service httpd stop
    /etc/init.d/httpd stop: httpd stopped
    [email protected] [~]# service httpd start
    Failed loading /ea/eaccelerator-0.9.3/modules/eaccelerator.so:  /ea/eaccelerator
    -0.9.3/modules/eaccelerator.so: cannot open shared object file: No such file or
    directory
    /etc/init.d/httpd start: httpd started
    [email protected] [~]#
    Would anyone please tell me what wrong is that ? and how to fix that proplem? Thanks alot

    p/s:
    When i add this in /usr/local/lib/php.ini :
    Code:
    extension="/ea/eaccelerator-0.9.3/modules/eaccelerator.so"
    eaccelerator.shm_size="16"
    eaccelerator.cache_dir="/tmp/eaccelerator"
    eaccelerator.enable="1"
    eaccelerator.optimizer="1"
    eaccelerator.check_mtime="1"
    eaccelerator.debug="0"
    eaccelerator.filter=""
    eaccelerator.shm_max="0"
    eaccelerator.shm_ttl="0"
    eaccelerator.shm_prune_period="0"
    eaccelerator.shm_only="0"
    eaccelerator.compress="1"
    eaccelerator.compress_level="9"
    Then it doesn't say anything when i restart apache. But if i add this in /usr/local/lib/php.ini :
    Code:
    zend_extension="/ea/eaccelerator-0.9.3/modules/eaccelerator.so"
    eaccelerator.shm_size="16"
    eaccelerator.cache_dir="/tmp/eaccelerator"
    eaccelerator.enable="1"
    eaccelerator.optimizer="1"
    eaccelerator.check_mtime="1"
    eaccelerator.debug="0"
    eaccelerator.filter=""
    eaccelerator.shm_max="0"
    eaccelerator.shm_ttl="0"
    eaccelerator.shm_prune_period="0"
    eaccelerator.shm_only="0"
    eaccelerator.compress="1"
    eaccelerator.compress_level="9"
    then it gives me a error above. I installed Zend after installed Eaccelerate 0.9.3. There wasn't update or anything, i install them both fresh. Thanks
    Last edited by AndyJ; 07-17-2005 at 02:59 PM.

  2. #2
    I dont think /ea/eaccelerator-0.9.3/modules/eaccelerator.so is actually there make 100% sure

  3. #3
    Join Date
    Apr 2003
    Posts
    356
    Check phpinfo and see if eaccelerator is there. Sometimes it'll give you that error but its really loaded. Happened to me couple times.

  4. #4
    im not familiar with this program but wont this take up a ton of cpu/ram?

    eaccelerator.compress_level="9"

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •