Results 1 to 8 of 8
  1. #1
    Join Date
    Jun 2004
    Posts
    105

    MYSQL Help - innodb_additional_mem_pool_size

    How can I set this to be higher in MySQL.

    MySQL keeps crashing with the error there is not enough memory I need to increase innodb_additional_mem_pool_size in my.conf

    Well there is no variable in my.conf with this.

    How do I add it? How much should I make it for MySQL to stop crashing?

  2. #2
    Join Date
    Jul 2005
    Posts
    62
    Sure thing.

    In the [mysqld] group, simpy add:
    set-variable = innodb_additional_mem_pool_size=XXM

    XX, of course, is the size in MB of pool.

    -Jeff

  3. #3
    Join Date
    Jun 2004
    Posts
    105
    You mean the mysqld group in the my.cnf file?

    The default is 2MB? Is the setting below correct if I wanted 4MB?

    Would is a typical setting for this varaible? Would doubling it be a safe bet. I run a forum with about 300 concurrent users.

    set-variable = innodb_additional_mem_pool_size=4

  4. #4
    Join Date
    Jul 2005
    Posts
    62
    I'd take it a bit higher than that as long as you've got the system RAM. Bump it to around 10MB. If you're running out at 2, an extra-heavy day might break you at 4.

  5. #5
    Join Date
    Jun 2004
    Posts
    105
    Then I just restart MySQL and the variable should be set? I don't have to change anything elsewhere just add that line to my.cnf?

    I have 1 gig of RAM.

  6. #6
    Join Date
    Jul 2005
    Posts
    62
    Nope, bounce it =) Then login and list your variables to see if it's set.

  7. #7
    Join Date
    Jun 2004
    Posts
    105
    Bounce it?

    How do you list your variables?

  8. #8
    Join Date
    Jul 2005
    Posts
    62
    Yes, restart the server =)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •