Results 1 to 14 of 14
  1. #1

    * Guys what can i do now

    Guys i have a problem with the server now ,there is a problem witht the mysql , its not working , i think i upgrade to newer version , i need any solution that can make the site working , its realy important guys , please help.
    this is the error i resive :
    Warning: mysql_connect(): Client does not support authentication protocol requested by server; consider upgrading MySQL client in /home/*****/public_html/index.php on line 78
    Could not connect to MySQL database



    i am using cpanel and redhate :

    thanks

  2. #2
    Join Date
    Dec 2004
    Location
    New York, NY
    Posts
    10,574
    Are you using MySQL 4.1?

    -GSV
    MediaLayer, LLC - www.medialayer.com Learn how we can make your website load faster, translating to better conversion rates for your business!
    The pioneers of optimized web hosting, featuring LiteSpeed Web Server & SSD Storage - Celebrating 10 Years in Business

  3. #3
    how can i know , i am noob in these stuff .
    please help

  4. #4
    Join Date
    Dec 2004
    Location
    New York, NY
    Posts
    10,574
    Login in WHM and then click on the Server Status icon. Next, click on the Service Status icon and it will say MySQL and a version name. Please let us know what the version is. Additionally, judging from your posts on WHT, I suggest you hire a server administrator to take care of this for you.

    -GSV
    MediaLayer, LLC - www.medialayer.com Learn how we can make your website load faster, translating to better conversion rates for your business!
    The pioneers of optimized web hosting, featuring LiteSpeed Web Server & SSD Storage - Celebrating 10 Years in Business

  5. #5
    If you upgraded mysql you probably forgot to upgrade mysql-client the mysql-client will install a new version that can connect to your upgraded mysql server.

    If you upgraded from Mysql.com download the client version and install it.

  6. #6
    mysql (4.1.11-standard)

  7. #7
    Join Date
    Dec 2004
    Location
    New York, NY
    Posts
    10,574
    OK do this:

    WHM Root >> Server Setup >> Tweak Settings >> Look for the box that says MySQL.

    "Use old style (4.0) passwords with mySQL 4.1 (required if you have problems with php apps authenticating)" Make sure you have selected that option. Once that's done, you will need to re-install the script and it will work.

    -GSV
    MediaLayer, LLC - www.medialayer.com Learn how we can make your website load faster, translating to better conversion rates for your business!
    The pioneers of optimized web hosting, featuring LiteSpeed Web Server & SSD Storage - Celebrating 10 Years in Business

  8. #8
    Join Date
    Mar 2003
    Location
    California USA
    Posts
    13,290
    i personally recommend recompiling php to use system mysql rather then using the old style passwords
    Steven Ciaburri | Industry's Best Server Management - Rack911.com
    Software Auditing - 400+ Vulnerabilities Found - Quote @ https://www.RACK911Labs.com
    Fully Managed Dedicated Servers (Las Vegas, New York City, & Amsterdam) (AS62710)
    FreeBSD & Linux Server Management, Security Auditing, Server Optimization, PCI Compliance

  9. #9
    Guys i need to hire someone to manage my server , do you guys recommend someone,and i need cheap prices too

  10. #10
    Join Date
    Dec 2004
    Location
    New York, NY
    Posts
    10,574
    Originally posted by freeboy1
    Guys i need to hire someone to manage my server , do you guys recommend someone,and i need cheap prices too
    www.serverwizards.com.

    Originally posted by thelinuxguy
    i personally recommend recompiling php to use system mysql rather then using the old style passwords
    You could do that too but, I was going for the simpler fix.

    -GSV
    MediaLayer, LLC - www.medialayer.com Learn how we can make your website load faster, translating to better conversion rates for your business!
    The pioneers of optimized web hosting, featuring LiteSpeed Web Server & SSD Storage - Celebrating 10 Years in Business

  11. #11
    thanks elix
    i solved the problem now , thanks alot

  12. #12
    Join Date
    Dec 2004
    Location
    New York, NY
    Posts
    10,574
    Originally posted by freeboy1
    thanks elix
    i solved the problem now , thanks alot
    Your welcome.

    Was it this that helped? (just for the record)
    Originally posted by elix
    OK do this:

    WHM Root >> Server Setup >> Tweak Settings >> Look for the box that says MySQL.

    "Use old style (4.0) passwords with mySQL 4.1 (required if you have problems with php apps authenticating)" Make sure you have selected that option. Once that's done, you will need to re-install the script and it will work.

    -GSV
    MediaLayer, LLC - www.medialayer.com Learn how we can make your website load faster, translating to better conversion rates for your business!
    The pioneers of optimized web hosting, featuring LiteSpeed Web Server & SSD Storage - Celebrating 10 Years in Business

  13. #13
    yah , i checked on the option Use old style (4.0) passwords with mySQL 4.1 (required if you have problems with php apps authenticating)"
    and then i upgraded the apeach again and it worked fine

  14. #14
    Join Date
    Dec 2004
    Location
    New York, NY
    Posts
    10,574
    Originally posted by freeboy1
    yah , i checked on the option Use old style (4.0) passwords with mySQL 4.1 (required if you have problems with php apps authenticating)"
    and then i upgraded the apeach again and it worked fine
    OK. Glad to hear everything works.

    -GSV
    MediaLayer, LLC - www.medialayer.com Learn how we can make your website load faster, translating to better conversion rates for your business!
    The pioneers of optimized web hosting, featuring LiteSpeed Web Server & SSD Storage - Celebrating 10 Years in Business

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •