Results 1 to 2 of 2
  1. #1
    Join Date
    Apr 2004

    Connection to Public IP error....

    Hi Geeks,
    I have a strange problem...
    Sometimes when my clients complain me that they are getting connection failure to my relay server ..(They see in maillog)

    Typical error is:
    Couldn't make an SMTP connection...

    Few days I ignored I thought it could be Coz of n/w problem at client's end..
    But incidently one client complained I tried to connect to public IP of server...for whom SMTP error was appreaing in log...
    And it failed via putty....

    I tried from different machines ., failed...

    Then I logged to one other server (in the same subnet)...and from there I did ssh to Public IP...again it failed..

    Then I tried to do ssh to local IP from that second server and it worked..

    But at the same time I was trying to connect to Public IP it was giving n/w error in Putty...

    Then I did tcpdump on eth0 which is a public ip 5 in it received 1 packet ...
    I restarted the n/w service....
    And then I was able to login to Putty from Public IP...
    But is it a n/w card issue or n/w issue or something else...

    My lspci o/p is of eth0/1 is

    01:00.0 Ethernet controller: Intel Corp. 82540EM Gigabit Ethernet Controller (re v 02)
    01:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (LOM) Ethernet Contr oller (rev 81)

    OS is redhat 8.0

    What could be problem...?
    Thinking Different !!

  2. #2
    Join Date
    Dec 2003
    Sunny So. Calif.
    If all the failures are on eth0 (public IP) then I would first try replacing that NIC (assuming it's not the on-board Pro/100VE). If it is the on-board NIC, then to verify, you'd have to either replace the MB or insert another PCI NIC and reconfigure things so the new one is eth0 and disable the on-board in CMOS.

    IMHO, this is usually the quickest way to verify if it's the NIC at fault. Others may disagree, but for me it only takes about 5 min to do this.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts