Results 1 to 5 of 5

Thread: FTP Restriction

  1. #1
    Join Date
    Nov 2004
    Posts
    257

    * FTP Restriction

    Running Fedora Core 2 with vsftp. Basically what Im trying to accomplish is when a user logs into ftp it currently goes directly to their home folder. What I dont want is them being able to go back one folder to the root of home and access the other account folders. How can I accomplish this?

    Thanks
    Silly

  2. #2
    Join Date
    Jun 2003
    Location
    United States of America
    Posts
    1,838
    this topic looks interestings, im gonna subscrube to see if any one post back
    Computer Steroids - Full service website development solutions since 2001.
    (612)234-2768 - Locally owned and operated in the Minneapolis, Minnesota area.

  3. #3
    Join Date
    Dec 2003
    Location
    Sunny So. Calif.
    Posts
    204
    Per vsftp's config docs, have you tried:

    chroot_local_user
    If set to YES, local users will be (by default) placed in a chroot() jail in their home directory after login. Warning: This option has security implications, especially if the users have upload permission, or shell access. Only enable if you know what you are doing. Note that these security implications are not vsftpd specific. They apply to all FTP daemons which offer to put local users in chroot() jails.

    Default: NO

    passwd_chroot_enable
    If enabled, along with chroot_local_user , then a chroot() jail location may be specified on a per-user basis. Each user's jail is derived from their home directory string in /etc/passwd. The occurrence of /./ in the home directory string denotes that the jail is at that particular location in the path.

    Default: NO

    Docs can be found at:

    http://vsftpd.beasts.org/vsftpd_conf.html

  4. #4
    Join Date
    Jan 2005
    Location
    Scotland, UK
    Posts
    2,539
    `man chmod`
    mainly 770
    Server Management - AdminGeekZ.com
    Infrastructure Management, Web Application Performance, mySQL DBA. System Automation.
    WordPress/Magento Performance, Apache to Nginx Conversion, Varnish Implimentation, DDoS Protection, Custom Nginx Modules
    Check our wordpress varnish plugin. Contact us for quote: sales@admingeekz.com

  5. #5
    Join Date
    Nov 2004
    Posts
    257
    Originally posted by jamesyeeoc
    Per vsftp's config docs, have you tried:

    chroot_local_user
    If set to YES, local users will be (by default) placed in a chroot() jail in their home directory after login. Warning: This option has security implications, especially if the users have upload permission, or shell access. Only enable if you know what you are doing. Note that these security implications are not vsftpd specific. They apply to all FTP daemons which offer to put local users in chroot() jails.

    Default: NO

    passwd_chroot_enable
    If enabled, along with chroot_local_user , then a chroot() jail location may be specified on a per-user basis. Each user's jail is derived from their home directory string in /etc/passwd. The occurrence of /./ in the home directory string denotes that the jail is at that particular location in the path.

    Default: NO

    Docs can be found at:

    http://vsftpd.beasts.org/vsftpd_conf.html
    Sweet! That worked. Thank you very much. Basically I did this:

    1. chroot_local_user=YES
    2. passwd_chroot_enable=YES
    3. Added username to vsftpd.chroot_list

    Now when I ftp with my account all I see is the directory under my home folder.

    The only sucky part is I have to manually add all ftp accounts to the list. But at least this does what I need it to do. Thanks again!

    Silly

  6. Newsletters

    Subscribe Now & Get The WHT Quick Start Guide!

Related Posts from theWHIR.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •